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Introduction 
This document describes the use of Griddle grid generation tools in conjunction with the Rhino CAD 
system.  

Griddle offers engineers and scientists both automatic and interactive grid generation capabilities that 
cover a wide range of volume grid generation needs as well as operations with surface meshes. Griddle 
provides new tools as well extensions to meshing tools available within Rhino CAD system. 

 

Detailed tutorial examples of geomechanical applications are provided in Griddle 2.0 Tutorial Examples 
document that can be accessed via Windows Start Menu → Itasca Griddle 2.0. The files for the tutorial 
examples can be accessed by clicking on Griddle 2.0 Tutorial Files link. The link opens user writable 
directory ProgramData\Itasca\Griddle200 (typically on drive ”C:”) which contains the 
documentation and the tutorial material. Users can directly work in this directory. A reserve copy of the 
same material can be found in the Documentation subfolder of Griddle installation location (typically 
in C:\Program Files\Itasca\Griddle200). 

This manual contains images showing snapshots of Rhino windows and dialogs. The images were 
generated in Rhino 6, but analogous dialogs and windows can be found in other versions of Rhino. 
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Quick Start for Griddle 2.0 and Rhino 
Griddle 2.0 is a suite of tools for surface- and volume-meshing within the Rhino CAD system. Griddle 2.0 
is installed as a Rhino plugin and is only available for the Windows versions of Rhino 6, 7, 8. 

The Griddle 2.0 installer automatically removes all previous versions of Griddle installed on the machine, 
including those for Rhino 5 and later. 

Rhino is installed separately from Griddle and is used for constructing model geometry. 

First Time Use After Installation 
• If previous versions of Griddle have never been installed, nothing else needs to be done and Griddle 

2.0 can be readily used. Griddle 2.0 automatically integrates with Rhino 6, 7, 8; the Griddle toolbar 
should be visible within the Rhino workspace: 

 
Figure 1: The Griddle 2.0 toolbar. 

• If Griddle 1.0 was previously installed, additional steps may be needed to remove parts of the older 
Griddle from Rhino1. After this one-time clean-up, Griddle 2.0 is ready to be used. The steps below 
are outlined for Rhino 6 but they can also be applied to other versions of Rhino to fully remove 
Griddle 1.0 components. 

1. Open Rhino. There may be two Griddle toolbars: an old one from v1.0 and a new one from v2.0. 

 
Figure 2: The Rhino 6 window with Griddle 1.0 and Griddle 2.0 toolbars. 

 
1 Griddle 1.0 used Rhino integration tools and required a multi-step installation process (separate installation of 
plugins for each command, toolbars, and scripts). Griddle 2.0 operates differently – it installs all components at 
once. During the installation, Griddle 2.0 attempts to remove its older versions from the system, but some parts 
may remain and should be removed manually. 
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2. The Griddle 1.0 toolbar should be removed from Rhino. To do this, navigate to the top menu in 
Rhino and click on Tools → Toolbar Layout… (for Rhino 5, 6, 7) or Window → Toolbars… (for 
Rhino 8). This displays toolbars that are open/loaded in Rhino. Find “Griddle100”, right click on it 
and select Close (do not Save when offered). 
 

WARNING: DO NOT CLOSE “Griddle” TOOLBAR - it is used by Griddle 2.0 
ONLY CLOSE “Griddle100” TOOLBAR 

 

 
Figure 3: Closing Griddle 1.0 toolbar from Rhino’s Toolbar Layout menu. 

3. Figure 2 shows that Rhino outputs a warning “Cannot find script file …ColorizeObjects.rvb”. This 
message may appear when Rhino starts. This occurs because the Griddle 2.0 installer removes 
Griddle 1.0 script files, however, Rhino is not aware of that (as these files were originally 
installed manually). Users may simply ignore this warning or may remove the reference to old 
scripts in Rhino to not have the warning. To do so, use the menu items Tools → Options → 
RhinoScript. Find “ColorizeObjects.rvb” in the list of scripts and delete it (click on ). 
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Griddle 2.0 Components 
This section provides a brief summary of Griddle 2.0 components. Each component can be accessed by 
clicking on an icon on Griddle toolbar or by typing a command that is the same as the component name 
(if Rhino is set up to use language other than English, type an underscore before the command, e.g. 
_GInt). 

Table 1. Griddle components. 

Icon 
Component name, 
Command (English) 

Description 

 BlockRanger Structured hexahedral volume mesher that operates on solids 

 GInt Surface mesh intersector for making meshes conformal 

 GSurf 
Unstructured surface remesher to create unstructured surface meshes 
with specified parameters 

 GVol Unstructured tetrahedral/hex-dominant volume mesher 

 GHeal A set of tools to identify and fix surface mesh problems 

 GExtract 
A set of tools to extract pieces of surface meshes based on user-
specified criteria 

 GExtend A set of tools to expand surface meshes along a specified boundary 

 GExtrude 
A set of tools to extrude surface mesh along its boundary to create a 
watertight domain 

 NonManifoldMerge 
Rhino command to merge surface meshes and create a single non-
manifold mesh 

 ColorizeObjects Assign random colors to objects 

 GriddleAbout Display information about Griddle and check for updates 

Detailed descriptions of these components are provided in later sections of this manual. 

Griddle 2.0 Licensing 
Griddle 2.0 requires a license to run all components with full functionality. The licenses can be provided 
via a local USB key (desktop license), a network USB key (network license) or through online Web 
licensing (using Itasca Web License portal). 

A license can be obtained by contacting www.itascacg.com/sales. 

http://www.itascacg.com/sales
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If a license is not present, Griddle 2.0 operates in demonstration mode. Demonstration mode limits 
Griddle functionality as described in Table 2. 

Table 2. Griddle 2.0 demonstration mode limits. 

Icon Component  Limitations in demonstration mode 

 BlockRanger Saves output volume mesh in VRML format only 

 GInt 
• Functionality to keep meshes separate (OutputMesh=Separate) is 

not available (all meshes will be merged in the output) 
• SplitIntersections option is not available 

 GSurf 

• Number of elements in the output mesh is limited to 5000 
• Functionality to keep meshes separate (OutputMesh=Separate) is 

not available (all meshes will be merged in the output) 
• Element/mesh quality information is not provided. 

 GVol 
• Number of elements in the output mesh is limited to 10000  
• Element/mesh quality information is not provided 

 GHeal Automatic mesh repair, AutomaticHeal, is not available 

 GExtract Only separation of a single surface (SingleSurface) is available 

 GExtend Not available in demonstration mode 

 GExtrude Not available in demonstration mode 

 NonManifoldMerge Fully available in demonstration mode 

 ColorizeObjects Fully available in demonstration mode 

 GriddleAbout Fully available in demonstration mode 

Note that BlockRanger is now integral part of Griddle 2.0 and therefore it requires a Griddle 2.0 license. 
Starting with Griddle 2.0, BlockRanger will not accept licenses from FLAC3D or 3DEC.  

Using Griddle network license 

If a network key is purchased, follow these steps to install Run-time Environment on the license server: 
1. Do not connect the network USB key to the server machine. Depending on the type of the key 

obtained, install on the server: 



Griddle v2.00.14, User Manual, rev112423  8 

- “Sentinel Protection Installer 7.7.0” (or any newer version) for Sentinel SuperPro or similar 
keys. Make sure that ports 6001 and 6002 are open for UDP and TCP connections. 

- “HASP_Setup” for Sentinel HL (green) keys. Make sure that port 1947 is open for UDP and 
TCP connections. 

Both utilities are provided within Griddle installation directory in Tools\Runtime; they both 
can be installed on the same machine. The utilities can also be downloaded from 
https://www.itascacg.com/software/support/utilities as part of ICG Tools package (navigate to 
Runtime folder). 

2. Connect the Griddle network USB key to the server. 
3. Start Rhino with Griddle on the user machine (make sure it has stable connection to the license 

server) and follow the steps described in the next section. 

Changing Griddle license location 
To change the type of Griddle license to be used or location, click on the   icon on Griddle toolbar or 
type the _GriddleAbout command and then click on Show or Change Griddle License button. A License 
Location dialog will open (it may take a moment to open as it tests connections to the existing licenses). 
Users can select desired license type in the dialog, test connection to the license and list license 
information. 

If using Griddle network license, enter the IP address of the license server or type localhost to use 
local machine as the server. 

Updating Griddle 2.0 
Griddle 2.0 is continuously being improved. Users may expect periodic updates. Griddle automatically 
checks for available updates each time Rhino is closed. If updated version is available, a message box will 
appear offering users to navigate to the download page. 

Users may also check for updates manually by clicking on the   icon on Griddle toolbar or typing the 
_GriddleAbout command. Besides displaying technical information about Griddle and license 
information, the Griddle About dialog notifies users when updates are available. 

Users may also check for updates by navigating to the Griddle update page:  
http://www.itascacg.com/ftp_pub/griddle/v200/griddle200.html 

The installer for Griddle updates removes previous versions prior to installing the update. 

  

https://www.itascacg.com/software/support/utilities
http://www.itascacg.com/ftp_pub/griddle/v200/griddle200.html
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Brief Introduction to the Rhino 6 (or later) Workspace 

The Rhino Command Area, Command Prompt, and Commands 
All Rhino operations are performed by commands. The command area and command prompt are shown 
in Figure 4. 

The command area is the field (generally on top) where Rhino displays system and command output 
information. Below the command area is the command prompt, where users can type Rhino or Griddle 
commands. The location of the command area can be moved by dragging. 

When a user clicks on any icon (including icons from the Griddle toolbar) or a menu item, a 
corresponding command is automatically issued and placed into the command prompt. For example, 

clicking on  from the Griddle toolbar issues the command _GSurf, as shown in Figure 4. 

 
Figure 4: The Rhino window featuring the Griddle toolbar and the Help pane. 

Another example is the command _CommandHelp, which opens the Help pane. If the Auto-Update 
checkbox is selected in the Help pane, it will display information about currently typed command, 
including Griddle commands, as shown in Figure 4. The same Help pane can be opened using Help → 
Command Help on the menu. The Help pane can be dragged (by grabbing the tab) and placed into any 
convenient location. 
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Note that if an underscore is placed before the command name (e.g. _Shade), Rhino assumes that the 
user refers to the English command name (i.e., Shade). Therefore, regardless of the language in which 
Rhino is set up, _Shade creates a shaded image whereas the command Shade will only be understood if 
the installation language is English. 

Throughout this manual, Griddle and Rhino functions are mostly referred through commands that are 
entered or issued in the Rhino command prompt. Sometimes Rhino functions are referred to by their 
icon name or through a menu item. The name of an icon is displayed in a tooltip that pops up when user 
hovers the mouse over the icon. Often, Rhino icons have two related functions depending on whether 
the user clicks the left or right mouse button (e.g., the commands _PointsOn and _PointsOff 
corresponding to the Rhino icon  ). 

Viewports, Rotating, and Panning Views 
Viewports are the part of the Rhino workspace where the user manipulates models. There are four 
standard viewports: Perspective, Top, Front, and Right, as shown in Figure 4. In the Perspective viewport, 
which presents a model in 3D perspective view, the user can rotate the view (right-click and hold) or pan 
the view using Shift and the right mouse button held down. The other viewports provide 2D views that 
only allow panning. The user may display several viewports simultaneously and may even create custom 
viewports. 

Object Snapping Options 
Two types of snapping are available in Rhino: Grid Snap and Osnap. When Grid Snap is enabled, moving 
the mouse while it controls an object (e.g., dragging or extending an object) will cause the mouse 
pointer to snap to discrete positions in space corresponding to the X, Y, Z position of grid nodes. 

To be able to snap lines, polylines, corners of objects, etc. to existing objects, Osnap must be active. 
Click on the Osnap at the bottom of the Rhino window to activate it. Next, specify which particular 
point(s) of an existing object may be snapped to by checking any of the words: End, Near, Point, Mid, 
etc. that appear at the bottom the Rhino window, as shown in Figure 4. 

Both snapping options can be active simultaneously. 

Units and Tolerances 
Rhino allows users to specify units when creating a new project. Units determine what is displayed when 
measuring distance, location, or angles. More importantly, units and object sizes are related to 
tolerances used by Rhino. By default, tolerance is determined based on model units. However, users can 
specify custom values (see Figure 5). 

Tolerances are very important when intersecting or doing Boolean and other operations with NURBS or 
SubD surfaces or BRep2 objects or when applying Rhino commands to meshes (note that Griddle’s GInt 

 
2 NURBS – non-uniform rational basis spline, SubD surfaces are high-precision Catmull-Clark subdivision surfaces 
(only in Rhino 7 and later), BRep – boundary representation; 
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tool has its own user-specified tolerance). Because these types of operations often do not provide exact 
(analytical) results but use approximate calculations or representations of objects, using proper 
tolerances ensures that operations are done as desired and in reasonable timespans. 

In all cases, make sure that the model is never too far away from the origin and, if it is, _Move it closer 
to the origin. Moving objects closer to the origin improves accuracy of operations and helps with the 
graphics both in Rhino and in the analysis software. 

 
Figure 5: The Rhino window to specify model units and tolerances.  

When starting a new project, use the appropriate Rhino template to specify whether the model will be 
using “Large Objects in Meters”, “Small objects in feet”, etc. After that create a model or import DXF, 
STL files, or even other existing 3dm files into the new project. This technique controls the tolerance 
(instead of using an inherited tolerance when starting from an imported file). 

More information on tolerance can be found in the References section (see: Understanding Rhino 
tolerances). 

Orthogonal Restriction of Mouse Movement 
Mouse movement can be restricted permanently to the X, Y and Z directions by clicking the word Ortho 
that appears at the bottom of the graphic window — or by pressing F8. Mouse movement may be 
temporarily restricted by holding down Shift while moving the mouse. 

Thicker lines  
The default representation of curves (1 pixel wide) may be too thin and difficult to see in a working area 
or when a Rhino window is projected on a screen. Figure 6 shows, at left, the default representation. 
The following procedure shows how to draw curves 3 pixels-wide whenever Shaded View is selected 
(Figure 6, right). 

Within Rhino, Select the Tools → Options menus item. In the left pane of the Rhino Options dialog, 
select View → Display Modes → Shaded → Objects → Curves. In the Curve Settings pane, to the right, 
change the default setting of Curve width from 1 to 3 pixels and click OK (Figure 7). These changes are 
saved with the project. 

 
NURBS surfaces – surfaces represented by non-uniform rational basis spline; SubD surfaces (only in Rhino 7 and 
later) represented by generalized higher order splines for extra smoothness (Catmull–Clark subdivision surface); 
BRep objects – objects represented by its boundaries. All these objects have (semi-)analytical description. 
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Figure 6: A regular (left) and “thick line” (right) representation.  

 
Figure 7: Setting line width to 3 pixels in Shaded View.  

Hiding the Background Grid 
Hide or show the background grid in an active viewport by pressing F7. To hide the grid in all viewports, 
go to Tools → Options. In the left pane of the Rhino Options dialog, click on Document Properties → 
Grid, and in the Grid properties section, uncheck Show grid lines and Show grid axes. 

Avoiding Accidental Object Dragging 
It is easy to inadvertently drag a highlighted object with the left mouse button. To avoid this, open menu 
item Tools → Options. In the left pane of the Rhino Options dialog, click on Rhino Options → Mouse, 
and in the Click and drag section, set the Object drag threshold to 100 pixels. Now, dragging an object 
requires a minimum of 100 pixels of mouse movement before it takes effect. 

A number of other customizations and helpful tips/information about Rhino can be found in the Rhino 
documentation (press F1 or navigate to Help menu).  
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Structured and Unstructured Meshes 
Griddle creates structured volume meshes using BlockRanger and unstructured volume meshes using 
GVol. BlockRanger operates on solids3 represented by BRep or NURBS objects. BlockRanger does not 
operate on closed SubD objects. GVol operates on sets of conformal surface meshes (structured or 
unstructured) which compose watertight (closed volume) domains. After executing BlockRanger or 
GVol, output file(s) with volume mesh data are created. The output contains information about nodes, 
faces, elements, node-face connectivity, node-element connectivity, and element and surface groups4. A 
mesh from such output can be imported into numerical modeling software (e.g. FLAC3D, 3DEC, ABAQUS, 
etc.) 

Structured meshes are identified by regular connectivity and typically have well-shaped elements 
(zones). Simple examples of structured meshes are (see examples in Figure 8, Figure 10, and Figure 12): 

• a quadrilateral mesh in 2D where each internal node is joined to 4 neighboring quadrilaterals, 
forming a regular array of elements, and 

• a structured 3D hexahedral grid that has each internal node connected to 8 elements. 

An unstructured mesh is identified by irregular connectivity. Surface unstructured meshes typically 
employ triangles and quadrilaterals, while an unstructured 3D volume mesh may contain tetrahedra, 
pyramids, prisms, hexahedra, and even more complex elements. Griddle’s components GSurf and GVol 
build triangular, quad-dominant, and pure quadrilateral surface meshes and tetrahedral and hex-
dominant unstructured volume meshes, correspondingly. 

Using an unstructured mesher typically provides the advantage of generating meshes for geometry of 
any complexity. It is typically much faster than the operations required to build a similar model with a 
mapped structured mesher (for cases when it is possible to use a structured mesher). 

Two examples below (Figure 8, Figure 9) illustrate the difference between structured and unstructured 
volume meshes created for the same initial geometry. The model includes a layered domain with several 
parallel curving tunnels that are intersected by another tunnel. 

Figure 8 shows a fully structured volume mesh that was created by decomposing the initial geometry 
into hexahedral, tetrahedral, and prism-like solids within Rhino. After such decomposition, the solids 
were meshed with BlockRanger. Preparing solids from the initial geometry in Rhino takes a considerable 
amount of time and effort. However, the resulting mesh is a high-quality, all-hexahedral structured 
mesh. 

Figure 9 illustrates a fully unstructured volume mesh that was generated using GVol. The volume mesh 
was created from surface meshes of tunnels and rock layers. Manual decomposition into simple 
primitive shapes/solids is not required in this case. Overall model creation is much faster. The resulting 
mesh is a good-quality hexahedral-dominant unstructured mesh. 

 
3 Solids are assemblies of surfaces, called polysurfaces in Rhino, that have a clearly defined interior and exterior. 
4 Element and surface groups currently are available only for output in FLAC3D, 3DEC and CSV formats. 
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For some models, like for the one presented in Figure 8 and Figure 9, it is also possible to create hybrid 
(mixed) meshes, in which the interior of the tunnels is structured mesh (meshed with BlockRanger) and 
the exterior volume is unstructured mesh (meshed with GVol). This is possible because tunnels have 
regular shape, while the overall shape of the model plus tunnel surfaces is irregular. These meshes 
would have to be created separately and output into separate files. Subsequently, they can be combined 
into a single mesh within numerical modeling software. 

 
Figure 8: All hexahedral structured FLAC3D mesh generated by BlockRanger. 

 
 

 
Figure 9: Hexahedral dominant unstructured FLAC3D mesh generated by GVol.  
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Using Griddle Tools for Structured Meshing - BlockRanger 
BlockRanger is an interactive all-hex mapped mesher. The Rhino command to run BlockRanger is _BR 
and the icon to run it is provided in Table 1. 

BlockRanger operates only on 4, 5 or 6-sided solids represented by a watertight BRep or NURBS objects 
(not SubD). It creates high-quality hexahedral (brick) volume mesh within such solids, which can be 
output in different formats for use in numerical modeling software. 

Admissible BlockRanger solids (Figure 10) are: 
• 6-sided solids (hexahedron-like) composed of 6 surfaces each bounded by 4 curves. 
• 5-sided solids (prism-like) composed of 2 triangle-like surfaces bounded by 3 curves and 3 quad-

like surfaces bounded by 4 curves. 
• 4-sided solids (tetrahedron-like) composed of 4 triangle-like surfaces each bounded by 3 curves. 

 

 
Figure 10: Rhino solids recognized by BlockRanger with example BlockRanger mesh patterns for each.  

If the selected solids are contiguous, BlockRanger ensures that the resulting grid maintains grid 
conformity and continuity across block corners, edges, and faces so that no dangling nodes will result. 

All solids successfully processed by BlockRanger are saved as grid files in a user-specified location or, if 
AutoOutputName option is specified – in the same location as the Rhino project. Solids that did not 
qualify or could not be successfully meshed remain highlighted onscreen. Use the _Invert and _Hide 
commands make these solids visible and correct them. 

BlockRanger Options  

BlockRanger options consist of two categories: Meshing settings and Output parameters. They are 
outlined below. If options have predefined or default values, they are provided in square braces. 

Meshing Settings 

MaxEdgeLength [value ≥ 0, default = 0] 
Maximum element (zone) edge length in model coordinates. If a default value of 0 is specified, this 
number is calculated as one tenth of the length of the longest edge in the model. 

MinEdgeResolution [value > 0, default = 3] 
Minimum number of elements across each Rhino solid edge. Its default value is 3. 
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TargetNumElements [value > 0, default = 1] 
Use this option to reduce the maximum element aspect ratio in the grid. BlockRanger will initially 
build a grid based on the prescribed MaxEdgeLength and MinEdgeResolution. In a typical block-
structured grid, as BlockRanger reduces the maximum aspect ratio, the number of elements (zones) 
increases. BlockRanger stops when the number of elements exceeds TargetNumElements. 

GenerateSurfaceMesh [None (default), ByModel, ByLayer, BySolid] 
This option specifies if surface mesh should be created on the boundaries of volume meshes. The 
surface mesh may be composed of external and internal boundary faces of the generated volume 
meshes: 
• If ByModel is selected, the surface mesh will correspond to the external surfaces of all meshed 

solids combined (whole model). 
• If ByLayer is selected, the surface mesh will correspond to the external surfaces of all meshed 

solids combined and the boundaries between solids in separate layers. 
• If BySolid is selected, the surface mesh will correspond to the external surfaces of each solid. 

Note that a single surface mesh is generated containing all boundary faces and it is placed in the 
default layer. The surface mesh is not saved into the output file; it is generated for use within Rhino 
model only (e.g., to quickly assess generated volume mesh by looking at its boundaries).  

OutputFormat = [FLAC3D, 3DEC_5x, 3DEC_7x, ABAQUS, ANSYS, NASTRAN, LS-DYNA, VRML, CSV] 
Format in which the resulting volume grid file should be saved.  

3DEC_5x stands for 3DEC v5.0 or v5.2, and 3DEC_7x stands for 3DEC v7.0 or later. When outputting to 
3DEC format, a rigid block is generated for every element. This output is equivalent to BlockType = 
Rigid in GVol. BlockRanger currently does not have capability to output to 3DEC deformable blocks 
format. 

When outputting to CSV format, several output files will be created: a file with general information, 
separate files with information about elements, faces, and nodes (a file with internal surfaces will not 
contain any information as BlockRanger does not operate on such objects). 

If the license key is not present, BlockRanger only allows outputting generated meshes in VRML 
format (see Demo limits in Table 2). 

FormatType= [Binary, Text] 
This option appears only if user selects OutputFormat = FLAC3D or 3DEC_7x. The option specifies the 
format of the output file: in binary or text (ASCII). Saving and loading (reading) files in binary format is 
faster compared to the text format but binary files are not human-readable. All other OutputFormat 
choices save in text format only. 

AutoOutputName [= N/A (default), UserDefinedName] 
This option specifies a string that will appear in the output filename along with other identifiers. For 
example, for a Rhino project named “RhinoProject.3dm”, a FLAC3D output in binary format will be 
named: “RhinoProject_UserDefinedName_Binary.f3grid”. If user specifies a string in this option, the 
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Save As pop-up dialog will not appear and the output file will be named automatically as described 
above. If AutoOutputName is not specified (= “N/A”), a Save As dialog will appear, asking the user to 
provide the output file name and location. Note that: 
• The value for this option is not saved: each time a user clicks on this option, a new string must be 

typed. To erase an existing string in AutoOutputName, click on the option and press Enter; this will 
cause a Save As dialog appear when executing BlockRanger. 

• When using this option, the output file will be saved in the same location as the Rhino project file. 
If a file with same name already exists in that location it will be overwritten. 

This option allows running BlockRanger in automatic mode without user interaction (i.e., the need to 
type file name and press OK / Cancel in the Save As dialog). This is particularly useful when invoking 
the _BR command from RhinoScript, PythonScript, or other Rhino tools and plugins. 

Local Edge Resolution Control 
BlockRanger controls local mesh resolution by manually setting individual edge resolution. A short 
example is provided below. Hands-on information can also be found in the Griddle 2.0 Tutorial 
Examples, Tutorial 4: Creating a Structured Mesh with BlockRanger. Figure 11 shows a model 
representing a 3D slope. The model consists of 8 solids. 

 
Figure 11: 3D slope example. 

Running BlockRanger using the default parameters results in the grid as shown Figure 12. 

Use the command _DupEdge to duplicate an edge from a Rhino solid and set the number of elements 
for that edge. For example, in Figure 13, the highlighted edge on the right side is duplicated first. Select 
duplicated edge and navigate to its Properties pane (or press F3). Enter number 8 in the Name field for 
the selected edge, which will be the resolution of the edge. A second edge is duplicated using _DupEdge 
(left side on Figure 13) and the number 5 is entered in its Name field. 

If BlockRanger is run again, this time making sure to include the edges in the selection with the solids, 
the resulting grid will be more refined at the location of the duplicated edges (Figure 14). Set the option 
GenerateSurfaceMesh=Yes to visualize the resulting surface mesh in Rhino. 
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Figure 12: BlockRanger generated mesh with default parameter values. 

 
Figure 13: Duplicated edges (highlighted) with a custom number of elements specified. 

 
Figure 14: BlockRanger generated mesh with specified edge resolution. 

Note that local edge resolution control takes precedence over automatically determined number of 
subdivisions per edge (based on the input parameters) only when it provides a larger number of 
elements for the edge (i.e., a finer mesh). Otherwise, the automatically determined number of elements 
is used. 
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Using Griddle Tools for Unstructured Meshing 
Besides the structured volume mesher, BlockRanger, which operates on Rhino solids, Griddle includes 
tools to work with surface meshes and tools to generate fully conformal unstructured volume meshes. 
These tools are grouped within the Griddle toolbar (see Figure 1, Figure 15, and Table 1).  

• GInt – surface mesh intersector (command: _GInt), 
• GSurf – unstructured surface remesher (command _GSurf), 
• GVol – unstructured tetrahedral/hex-dominant volume mesher (command: _GVol). 

 
Figure 15: Griddle tools for unstructured meshing. 

All three functions operate directly on Rhino surface meshes. The meshing workflow to generate an 
unstructured volume mesh is summarized in Figure 16. 

 
Figure 16: Typical workflow for unstructured meshing using Griddle tools. 

Rhino has a rich set of surface meshing tools that allow users to create (e.g., by triangulation) and edit 
3D surface meshes for objects represented by NURBS, SubD, or BRep surfaces and polysurfaces. These 
meshes, although good for machining and prototyping purposes, are usually not suitable for numerical 
computations. Rhino-generated (or imported) surface meshes often must be properly intersected and 
remeshed with GInt and GSurf, respectively. Once a desirable watertight set of surface meshes is 
obtained, it can be used (along with internal surface meshes) as an input to GVol, which fills the interior 
regions bounded by the surface meshes with tetrahedra or hex-dominant (hexahedra, prisms, pyramids 
and tetrahedral) elements for the use in numerical programs (such as FLAC3D or 3DEC). The options for 
GInt, GSurf, and GVol are described below (and in the Help pane).  

Numerous examples describing the use of GInt, GSurf, and GVol to create unstructured volume meshes 
are provided in Griddle 2.0 Tutorial Examples. 
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GInt – Surface Mesh Intersector 

Griddle’s tool GInt is a surface mesh intersector that can be applied to improperly intersected surface 
meshes to make them conformal.  

• In conformal surface meshes, edges and nodes of mesh elements (faces) are fully shared 
between all elements connected to them. 

• In conformal volume meshes, element faces, edges and nodes are fully shared between all 
elements connected to them. 

Figure 17, left, shows a simple example of two non-conformal meshes in contact (blue and yellow 
meshes). After application of GInt, some of the initial faces are (randomly) split in triangular and 
quadrilateral faces to create conformal contact between meshes. 

 
Figure 17: Example of non-conformal (left) and conformal (right) 2D meshes. 

Figure 18 shows a more complex example of GInt operation on two meshes intersecting in non-
conformal fashion (left image). After application of GInt to both meshes (right image), intersecting faces 
(darker green and pink) are split into numerous triangular faces to provide conformal contact.  

      
Figure 18: Example of non-conformal (left) and conformal intersecting surface meshes (right) after using GInt. 

GInt can operate on multiple surface meshes at once to make the meshes themselves as well as 
intersections and contacts between them fully conformal. Use of GInt before continuing with meshing is 
typically needed as Griddle meshing tools GSurf and GVol require conformal surface meshes at input 
(see the workflow in Figure 16). 

Note that GInt internally operates on triangular meshes only. Therefore, if an input surface mesh 
contains quadrilaterals, these quadrilaterals are automatically converted into triangles (by arbitrarily 
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inserting one of the two possible diagonal edges splitting the quad face) prior to GInt running (as in 
Figure 18). GInt has an option to restore some of the planar quadrilaterals (as in Figure 17) but they may 
not match the original ones. 

If surface meshes are generated from Rhino NURBS, SubD, or BRep objects, it is better first to intersect 
such objects with Rhino’s Boolean functions or merge them with the _NonManifoldMerge command. 
After that the objects should be meshed (triangulated) with the _Mesh command and then remeshed 
with GSurf. Intersecting/merging of NURBS, SubD, or BRep objects is more accurate than intersecting 
their mesh representation as meshes always approximate the initial analytical surfaces. 

GInt Options 

MeshType [= Tri (default), Mixed] 
This option specifies the type of the output mesh. By default, it is a triangular mesh (Tri), however, if 
user selects the Mixed type, the output mesh will contain triangular and quadrilateral faces 
(elements). Quad faces are obtained by merging neighboring planar or near-planar triangular faces 
(only if the angle between face normals ≤ 0.5° and if the ratio of the diagonals in the resulting quad is 
less than 5). The Mixed option may be useful to preserve not-intersected quad faces in planar patches 
of the input meshes. In rare cases using this option may cause the output mesh to lose conformity (if 
two triangular faces across a previously non-conformal intersection are merged into a quad). This 
option is equivalent to using Rhino’s command _QuadrangulateMesh. 

Tolerance [value ≥ 0, default = 0] 
Tolerance is the most important parameter of GInt. It is an absolute distance (in model units) used to 
determine whether mesh faces intersect each other. If zero tolerance is specified, only those faces are 
intersected which are in exact contact with each other. Specifying non-zero tolerance allows searching 
for nearly intersecting faces (i.e., those within the tolerance). On the other hand, a very large 
tolerance may lead to a distorted output mesh as nodes within the tolerance are merged together. 

AdvancedParameters 

OutputMesh [= Separated (default), Merged] 
By specifying Separated value, GInt will try to associate output mesh patches (sub-meshes) with the 
distinct input meshes and will place them into the layers they were originally obtained from. Patches 
that could not be associated with a source mesh are placed into a layer “MISMATCHED_PATCHES”. 
When the value Merged is selected, a single output mesh will be generated and placed in the active 
layer. 

SplitInersections [= Yes, No (default)] 
If Yes is specified, GInt will split intersected faces from the rest of the mesh. If the user specifies 
OutputMesh = Separated, each set of split faces will be placed into a sub-layer “IntersectedFaces” of 
the original mesh layer. If the output mesh is merged, a new top-level layer named 
“IntersectedFaces” will be created, and all intersected faces will be placed in it (as a single merged 
mesh). 
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Note that if a high Tolerance is used, GInt may not only intersect faces between separate meshes 
but also may change faces within each mesh internally (mostly due to node merging). In such cases, 
if OutputMesh = Separated, the algorithm for detecting intersected faces may additionally report 
some non-intersected faces (therefore, Tolerance should be as small as possible when using this 
option). 

Extracting intersected faces allows operation on them (e.g., change name/layer, delete layer, etc.) or 
assigning specific mesh sizes to them (for example, to densify meshes around the intersections). 

DeleteInput [= Yes (default), No] 
Specifying Yes indicates that the original selected meshes will be deleted. If No is selected, the 
original meshes will remain intact. 

Reset resets advanced parameters to the default values. 

 
After GInt completes the operation, it outputs a text (ASCII) log file with information about input and 
output meshes. The log file uses the name of Rhino project file (e.g. “RhinoProject.3dm”) and adds 
“_GInt.log” to it (e.g. “RhinoProject_GInt.log”). The file is saved in the same directory where Rhino 
project is saved. 
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GSurf – Surface Remesher 

Griddle’s tool GSurf is a surface remesher that is used to remesh selected surface meshes to desired 
element size (on average) and type (triangle, quad-dominant, or all-quad). Surface meshes are used as 
input into the Griddle volume mesher GVol. The volume mesher uses the surface meshes to determine 
solid element size and type. Input surface mesh faces will appear as faces of solid elements in the 
volume mesh; thus, it is important to create good quality surface meshes before sending them to GVol. 
Input to GSurf must be one or more conformal (properly intersected) meshes or meshes that do not 
intersect at all. 

The example in Figure 19 shows the result of application of GSurf to the meshes presented in Figure 18, 
right. The left image shows the conformal quad-dominant surface meshes remeshed to element size5 5-
10m. The right image in Figure 19 shows same meshes but remeshed with local size control specified on 
the intersected (and extracted) patches of the input meshes (darker green and pink mesh patches in 
Figure 18, right). The local size for the patches was set to 0.5m while the global element size was set to 
5-10m (see sections below on how specify local element size). GSurf creates a smooth transition 
between different element sizes. The gradation can be controlled. 

      
Figure 19: Examples of remeshing with GSurf without (left) and with local size control (right). 

GSurf Options 

Mode [Tri (default), QuadDom, AllQuad] 
This option allows to choose the type of the output mesh: 

• Tri produces an all-triangle surface mesh. 
• QuadDom produces a quad-dominant surface mesh (contains a mix of triangles and 

quadrilaterals). 
• AllQuad produces a pure quadrilateral surface mesh. In certain cases, it is impossible to create 

an all-quad mesh and GSurf may show an error. In this case use QuadDom mode instead. 
 

 
5 In this case, element size is determined by the average value between element edge sizes. 
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MinEdgeLength, MaxEdgeLength [value > 0] 
These parameters control the output element size by setting minimum and maximum allowed edge 
sizes in the final surface mesh. To get uniform sizes, minimum and maximum edge size can be set to 
the same value. Edge size is specified in model units. It is important to set a non-zero minimum edge 
length to get a good quality output mesh. 

Note that these values are not strictly enforced in the output mesh. However, GSurf attempts to 
achieve provided limits on edge size through multiple remeshing optimization passes (see 
Optimization below). 

RidgeAngle [value between 0° and 90°, default = 20°] 
RidgeAngle, specified in degrees, controls the level of detail (the number of ridge lines) in the resulting 
mesh. The angle between mesh faces sharing an edge is termed a ridge angle (angle = 0° if faces are 
coplanar and 90° if faces are perpendicular). Ridge lines can be traced through the surface mesh by 
joining edges of faces that have ridge angles greater than the specified RidgeAngle. Using higher value 
for RidgeAngle results in less ridge lines (less detail) included in the final mesh. A lower RidgeAngle 
results in more detail included in the final mesh. Generally, RidgeAngle should be kept below 45°. The 
default value of 20° is a good compromise between mesh size and fidelity. 

AdvancedParameters 

MaxGradation [value > 0, default = 0.1] 
This parameter controls the gradation of element sizes. A value close to 0 leads to a more gradual 
variation of mesh size (smoother), while higher values lead to more abrupt changes in element size. 

Optimization [value between 0 and 10, default = 5] 
This parameter controls the optimization of the mesh. A zero value makes GSurf skip the 
optimization step; the remeshing speed is the highest in this case, but the quality may be poor. From 
value 1 on, the optimizer algorithm uses several techniques to improve both the shape quality and 
the size quality of the elements, such as node smoothing, edge swapping, node insertion, and node 
removal. Level 5 is usually a good trade-off between quality and speed. 

QuadWeight [value between 0 and 1, default = 0.75] 
QuadWeight controls the preference of quadrilaterals vs. triangles in the output mesh. This 
parameter is used only in quad-dominant meshing mode. If QuadWeight = 0, quadrilaterals are 
never used. If QuadWeight = 0.5, quadrilaterals are used only when they improve the quality of the 
mesh. For values between 0.5 and 1, quadrilaterals are used more even if it leads to a lesser quality 
mesh. If QuadWeight = 1, the minimum number of triangles is used. This parameter is not the ratio 
between the number of quads and triangles. Furthermore, there is no linear relation between 
QuadWeight and the ratio between number of quads and triangles.  

ShapeQuality [value between 0 and 1, default = 0.7] 
ShapeQuality controls the trade-off between shape optimization and size optimization. The default 
value (0.7) gives a slightly stronger preference to the element shape quality over the size quality. For 
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example, an elongated surface mesh patch can be remeshed using few elongated triangles or quads 
(if ShapeQuality is close to 0) or it can be remeshed with many almost perfect triangles or quads (if 
ShapeQuality is close to 1). 

OutputMesh [= Separated (default), Merged] 
By specifying OutputMesh = Separated, GSurf will try to associate output mesh patches (sub-
meshes) with the distinct input meshes and will place them into the layers they were originally 
obtained from. Patches that cannot be associated with a source mesh are placed into a layer 
“MISMATCHED_PATCHES”. When Merged value is selected, a single output mesh will be generated 
and placed in the active layer. 

DeleteInput [= Yes (default), No] 
Specifying Yes in this parameter indicates that the original selected meshes will be deleted. If No is 
selected, the original meshes will remain intact. 

Reset resets advanced parameters to the default values. 

 

Additional Edge Size Control Options 
In addition to the global values of min and max edge size specified in the parameters above (which are 
applied to all selected meshes), local overrides can be made to specify the desired element size for a 
surface mesh. Local values supersede the min and max edge sizes for the mesh. 

Local element size for a mesh can be specified in one of two ways:  

1. By specifying element size via a hyperlink available through object properties (Figure 20):  
• Select mesh 
• Open the Properties pane and click on the ellipsis (...) next to the Hyperlink property 
• In the Hyperlink dialog choose Type: (other) and type in the URL field “elemsize:NumericValue”. 

Click OK. No spaces are allowed in the URL field. 

2. By setting mesh name in the Properties pane to a numeric value representing the required element 
edge size (see image below). 

Griddle first checks if element size is specified in the Hyperlink field and if nothing is found, it will check 
the Name field for a numeric value. Specifying local element size via hyperlink is preferred for a few 
reasons: clean syntax; the mesh name can contain digits that may be confused with element size; and, if 
the mesh name should not be modified. 

Figure 20 shows two ways to specify local element size (Name field or Hyperlink). In this example only 
the yellow part of the mesh is assigned local element size, after which all meshes are remeshed with 
GSurf. The result of remeshing (bottom image) shows a much finer mesh at and around the yellow part, 
which corresponds to the provided element size. 
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Figure 20: Two ways to specify local element size for surface meshes. 

Similarly, local element size can be specified locally at a point, by creating a point (with Rhino's _Point 
command) and assigning a numeric value to the point's hyperlink or name (as shown above). Such 
points must be coincident with the existing mesh vertices (enable vertex snapping in Rhino to snap the 
new point to a mesh vertex). If no element size is specified at a point, such a point will be treated as a 
hard node and will become a mesh vertex in the output mesh. Element size around this point will be 
determined automatically. 

 
Figure 21: Specifying local element size at a point. 
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Hard Edges and Hard Nodes 
Hard edges are edges that are preserved in a mesh during the remeshing process. Consider an example 
in Figure 22 (left), which shows two conformal surface meshes. If one of the meshes (for instance, the 
red mesh) is changed (for example, refined) while the other is unmodified, the conformity of the meshes 
will be broken. GSurf offers a way to remesh a specific or all meshes while preserving conformity along 
mesh edges. This can be done by creating hard edges. 

1. Use Rhino's _DupBorder command on the red mesh, which will duplicate the mesh border (i.e., 
will create a curve connecting only nodes on the mesh boundary). Delete unnecessary segments 
of the curve (use the _SubCrv command) leaving only those segments that connect to the green 
mesh (as shown in Figure 22, left). 

2. Select both the red mesh and the remaining part of the curve (polyline) and call GSurf with 
desired meshing parameters (in this case, smaller edge size). GSurf will recognize the polyline as 
a hard edge and will remesh the red mesh, taking the hard edge into account. 

The remeshed red mesh will be finer, and both meshes will still be conformal. 

 

 
Figure 22: Specifying hard edges. 

Similarly, a hard node can be defined to preserve a location of a vertex. Information about hard nodes is 
provided in the previous section. 

Mesh and Element Quality Information; Output Log 
GSurf outputs information about input and output meshes, meshing parameters, and element quality 
information to a log file (ASCII). The element quality information is based on shape quality analysis of 
each element in the remeshed mesh. The following information is provided. 

• Total area: The cumulative surface area of all elements in the remeshed mesh in model 
units. 

• Element min shape quality (QS) value: Minimum normalized shape quality 
among all elements in the remeshed mesh. The values of shape quality range between 0 and 1. 
Detailed information about shape quality calculations is provided below. 
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• Max error distance: Measure of the geometric error between the input and output 
(remeshed) meshes. The nodes of the remeshed mesh are located exactly on the input mesh 
surface. However, this is typically not the case for the centroids of new elements, and new 
nodes may not coincide with the initial nodes. If the input mesh surface is not flat, the remeshed 
mesh may be some distance away from it. The Max error distance parameter is a 
measure of this maximum distance (Hausdorff distance). 

• Histogram QS for (All/Specific) Elements: Provides information about 
distribution of shape quality (QS) values. The bins (intervals) of the histogram are of equal size. 

o Total number of bins: Number of bins (intervals) in the histogram. The default 
value is 11. 

o Total number of counts: Total number of counts in the histogram equal to the 
number of elements (all or specific type, e.g., quadrilaterals) in the output mesh. 

o Number of larger values: Number of hits (elements) with QS above the 
largest histogram bin value. 

o Number of smaller values: Number of hits (elements) with QS below the 
smallest histogram bin value. 

o V max: Maximum shape quality (QS) value among all values in the histogram. 
o V mean: Mean shape quality (QS) value among all values in the histogram. 
o V min: Minimum shape quality (QS) value among all values in the histogram. 

Next, the information about shape quality values distribution in the histogram is provided: 
Bin number       -- Bin boundaries --          Hits 

Shape quality of an element QS is calculated based on the following expressions: 

For triangular elements: 𝑄𝑄𝑠𝑠 = 4√3 𝑆𝑆 (𝐿𝐿𝑚𝑚𝑚𝑚𝑚𝑚𝑃𝑃)⁄ , where 
- S is the area of the triangle,  
- Lmax is the length of the longest edge of the triangle,  
- P is the perimeter of the triangle. 

For 3D quadrilateral elements: 𝑄𝑄𝑠𝑠 = 𝑄𝑄𝑠𝑠2𝐷𝐷𝑄𝑄𝑤𝑤  
Here, 𝑄𝑄𝑠𝑠2𝐷𝐷 is 2D shape quality: 𝑄𝑄𝑠𝑠2𝐷𝐷 = 8√2 𝑆𝑆𝑚𝑚𝑚𝑚𝑚𝑚 (𝐿𝐿𝑚𝑚𝑚𝑚𝑚𝑚𝑃𝑃)⁄ , where 

- Smin is the minimum area of the four triangles within the quadrilateral,  
- Lmax is the max length of the four sides and the two diagonals,  
- P is the perimeter of the quadrilateral, 

- and  𝑄𝑄𝑤𝑤  is warp quality of the quadrilateral:  𝑄𝑄𝑤𝑤 = 1 − 𝑎𝑎𝑎𝑎𝑎𝑎𝑎𝑎(𝑚𝑚𝑚𝑚𝑚𝑚[〈𝑛𝑛0,𝑛𝑛2〉,〈𝑛𝑛1,𝑛𝑛3〉])
𝜋𝜋

,     where 

𝑛𝑛𝑖𝑖 is the normal at node i (or normal to the triangular face i of the quadrilateral). 

The output log file uses the name of the Rhino project file (e.g., “RhinoProject.3dm”) and adds 
“_GSurf.log” to it (e.g., “RhinoProject_GSurf.log”). The log is output to the same directory where the 
Rhino project is saved.  
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GVol – Unstructured Volume Mesher 

GVol is Griddle’s unstructured volume mesher, capable of creating a tetrahedral or a hex-dominant 
mesh using selected surface meshes as boundaries (Figure 23). Surface meshes can be composed of 
triangles, a mix of quadrilaterals and triangles, or all quadrilaterals. The latter two must be used for 
generating hex-dominant grids. Tetrahedral grids can be generated from triangle, triangle-quad, or all-
quad surface meshes (quadrilaterals are arbitrarily split along one of their diagonals into triangles).  

There are two important requirements for GVol to successfully create a volume mesh:  

• a combination of selected surface meshes must form a watertight boundary surrounding the 
entire volume of interest, and 

• all intersecting or connecting surface meshes must be conformal. 

Surface meshes can also separate discrete volumes within the larger volume. Surface meshes can also 
“float” inside the volume of interest or be partially connected to other surface meshes. All surface mesh 
faces, including “floating” surface meshes inside a volume, are included as “hard faces” in the final 
volume mesh. This means that all input surface faces will be present as faces of elements in the resulting 
volume grid. 

 
Figure 23: Volume mesh creation from surface meshes. 

GVol requires input surface meshes to be properly connected. Duplicate, overlapping, or intersecting 
surface mesh faces are not allowed. Check the mesh for errors with Griddle’s GHeal tool and fix issues, if 
needed (note that remeshing may be required after fixing issues). If issues remain after using GHeal, 
consider intersecting surface meshes using GInt and specifying a higher tolerance and remeshing all 
meshes again. 

If GVol encounters problems during meshing, traces of the problem areas will be placed into a Rhino 
layer “MESHING_ERRORS” (Figure 24). This layer will contain Rhino curves and points, outlining areas of 
surface meshes that caused problems. Typically, these problems are caused by the presence of naked 
edges (holes) or non-conformal (not properly intersected) mesh faces. 
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Figure 24: Traces of problem areas placed in “MESHING_ERRORS” layer. 

GVol options 

MeshSettings  

Mode [Tet (default), HexDom] 
This option specifies the type of the output mesh: 
• Tet (default) produces an all-tetrahedral volume mesh. Any quadrilaterals on surface meshes 

are converted to triangles in this case. 
• HexDom produces a conformal hex-dominant volume mesh. Input surfaces must contain 

quadrilaterals for this option. 

MaxGradation [value > 0, default = 0.5]  
This parameter controls the gradation of element sizes from the size on the boundary to the 
preferred size defined by TargetSize inside the domain (far enough from the boundaries). A value 
close to 0 leads to a more gradual variation of size while higher values lead to more abrupt changes 
in element size. 

TargetSize [value > 0, default = 0]  
This parameter specifies the preferred element size inside the domain. The element size tends 
toward this value as elements get away from the boundaries. The default value of 0 indicates that 
the element size inside the domain is automatically determined based on the size of the elements 
on the boundary faces. Make sure that this parameter is meaningful and is not too small compared 
to the elements size on the boundary faces; otherwise, mesh generation may take a very long time 
as a large number of small elements will be generated inside the domain. 

Optimization [value between 0 and 10, default = 5] 
This parameter controls the optimization of the mesh. A zero value makes the mesher skip the 
optimization step. The speed is the highest, but the quality may be poor. From value 1 on, the 
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optimizer algorithm uses several techniques to improve both the shape quality and the size quality 
of the elements, such as node smoothing, edge swapping, node insertion and node removal. Level 5 
is usually a good trade-off between quality and speed. 

ShapeQuality [value between 0 and 1, default = 0.7] 
This parameter controls the trade-off between shape optimization and size optimization. The 
default value (0.7) gives a slightly stronger preference to the element shape quality over the size 
quality. For example, an elongated volume region can be filled with few elongated elements (if 
ShapeQuality is close to 0) or it can be filled with many almost perfect elements (if ShapeQuality is 
close to 1). 

IniErrorCheck [= Yes, No]  
IniErrorCheck specifies if an error check for input surface meshes should be executed to detect 
potential problems with naked edges and/or clashing faces. The error check is executed before 
volume meshing begins, and if problems are found, a warning message will be shown. The initial 
error check can be turned off by setting this option to No. Griddle remembers this option even after 
Rhino is closed, therefore if IniErrorCheck is set to No, next time Rhino is launched, the initial error 
check will not run. To re-enable the check, set it to Yes. It is recommended to keep IniErrorCheck = 
Yes to be able to see warnings about input mesh problems. Changing this option does not affect 
other error checks during and after volume mesh generation. 

OutputFormat [= FLAC3D, 3DEC_5x, 3DEC_7x, ABAQUS, ANSYS, NASTRAN, LS-DYNA, VRML, CSV] 
OutputFormat specifies format in which the resulting volume grid file should be saved. 

FormatType [= Binary, Text] 
This option appears only if the user selects OutputFormat = FLAC3D or 3DEC_7x (i.e., 3DEC v7.0 or 
higher). The option sets how to save the output file: in binary or text (ASCII) format. Saving and 
loading (reading) files in binary format is much faster compared to the text format, but binary files are 
not human-readable. All other OutputFormat choices allow saving in text format only. 

BlockType [= Rigid, Deformable] 
This option appears only if user selects OutputFormat = 3DEC_7x (i.e., 3DEC v7.0 or higher). It specifies 
if each element of the output volume mesh should be represented as a rigid block (BlockType = Rigid) 
or as a deformable zone (BlockType = Deformable) in 3DEC. In the latter case, watertight volumes in 
the model (closed volumes separated by surface meshes) will be represented as rigid blocks filled with 
deformable zones. 

AutoOutputName [= N/A (default), UserDefinedName] 
This option sets a string that will appear in the output filename along with other identifiers. For 
example, for a Rhino project named “RhinoProject.3dm”, a 3DEC rigid blocks output in binary format 
will be named: “RhinoProject_UserDefinedName_Rigid_Binary.3dgrid”). If the user specifies a string in 
this option, the Save As dialog will not appear, and the output file will be named automatically as 
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described above. If AutoOutputName is not specified (N/A), the Save As dialog will appear in order to 
obtain the output file name and location. 
• Note that the value for this option is not saved: each time user clicks on this option, a new string 

must be typed. To erase the existing string in AutoOutputName, click on the option and press 
Enter without typing anything; this will cause the Save As dialog appear when executing GVol. 

• The output file will be saved in the same location as the Rhino project file. If a file with same name 
already exists in that location, it will be overwritten. 

• This option allows running GVol in automatic mode without user interaction (i.e., the need to type 
file name and press OK / Cancel in the Save As dialog). This is particularly useful when invoking 
the GVol command from RhinoScript, PythonScript, or other Rhino tools and plugins. 

Important Notes 
If OutputFormat = 3DEC_7x and BlockType = Deformable, block joints will not be created along floating 
surface meshes located (fully or partially) within watertight volumes that will become rigid blocks 
(Figure 25). Such floating surface meshes (meshes with naked edges) do not split or define separate rigid 
blocks and currently cannot be represented as joints in 3DEC (though, they can be represented as 
interfaces in FLAC3D). To check for the presence of surface meshes with naked edges, set IniErrorCheck 
= Yes and/or use the _GHeal command. 

 
Figure 25: Rhino model (left) with floating surface (red) and Joint plot in 3DEC representing the rigid block (right). The red 

surface does not become part of the rigid block (or a joint) in 3DEC. 

Mesh and Element Quality Information; Output Log 
GVol outputs information about input and output meshes, meshing parameters, and element quality 
information to a log file (ASCII). The element quality information is based on shape quality analysis of 
each element in the volume mesh. The following information is provided. 

• Meshed volume: The volume of all elements in the output mesh in model units. 
• Number of meshed subdomains: Number of closed volume (watertight) subdomains 

present in the meshing volume. 
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• Missed (unenforced) faces: For the case of a Hex-dominant volume mesh, GVol may 
be unable to use some constrained (boundary) quadrilaterals from the input surface meshes to 
generate 3D elements adjacent to them (for example, warped or very poor-quality quads). 
Mainly this is because it would lead to degenerate 3D elements or elements with very poor 
shape quality. In these cases, the constrained quadrilaterals are replaced by two triangles, which 
leads to generation of adjacent tetrahedrons (or sometimes pyramids). The parameter Missed 
(unenforced) faces shows how many unenforced (split) quadrilaterals are encountered. 
To enforce more boundary face quadrilaterals, increase the parameter Optimization level. Other 
entities that cannot be enforced, such as nonconformal faces, are also included in this 
parameter. 

• Element min shape quality (QS) value: Minimum normalized shape quality 
among all elements in the volume mesh. Shape quality value ranges between 0 and 1. Detailed 
information about shape quality calculations is provided below. 

• Histogram QS for (All/Specific) Elements: Provides information about 
distribution of shape quality (QS) values. The bins (intervals) of the histogram are of equal size. 

o Total number of bins: Number of bins (intervals) in the histogram. The default 
value is 11. 

o Total number of counts: Total number of counts in the histogram equal to the 
number of all/specific elements in the output mesh. 

o Number of larger values: Number of hits (elements) with QS above the 
largest histogram bin value. 

o Number of smaller values: Number of hits (elements) with QS below the 
smallest histogram bin value. 

o V max: Maximum shape quality (QS) value among all values in the histogram. 
o V mean: Mean shape quality (QS) value among all values in the histogram. 
o V min: Minimum shape quality (QS) value among all values in the histogram. 

Next, the information about shape quality values distribution in the histogram is provided: 
Bin number       -- Bin boundaries --          Hits 

Shape quality of an element QS is proportional to the minimum normalized Jacobian of the element. 
Element shape quality typically ranges from 0 for a degenerated element to 1 for a perfect element, 
however negative QS values may potentially be reported if warped elements (for which min Jacobian is 
negative) are present in the mesh. GVol typically avoids creating such elements either by splitting 
boundary quadrilaterals (if they are close or connected to the degenerate element) or by generating 
several simpler topology elements (e.g., tets, pyramids) in place of the warped element. 

For tetrahedral elements: 𝑄𝑄𝑠𝑠 = 6√6𝑉𝑉 (𝐿𝐿𝑚𝑚𝑚𝑚𝑚𝑚𝑆𝑆)⁄ , where 
- V is the volume of the tetrahedron, 
- Lmax is the length of the longest edge of the tetrahedron, 
- S is the total area of the four faces of the tetrahedron. 

Note that the Jacobian of a linear tetrahedral element is equal to six times its volume. 
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For other 3D elements: 𝑄𝑄𝑠𝑠 = 𝛼𝛼𝑄𝑄𝑤𝑤𝑚𝑚𝑚𝑚𝑚𝑚 ∙ 𝐽𝐽𝑚𝑚𝑚𝑚𝑚𝑚 𝐿𝐿3⁄ , where 
- 𝛼𝛼 is the scaling factor to scale to 1 for a perfect element (different for each element type), 
- 𝑄𝑄𝑤𝑤𝑚𝑚𝑚𝑚𝑚𝑚 is the minimum warp quality of the quadrilateral for elements containing such faces (see 

expression for Qw in the GSurf Section); 𝑄𝑄𝑤𝑤𝑚𝑚𝑚𝑚𝑚𝑚 = 1 for triangular faces, 
- 𝐽𝐽𝑚𝑚𝑚𝑚𝑚𝑚 is the minimum of the Jacobians calculated at all the vertices (equals to the determinant of 

the mixed product of 3 edge vectors at each vertex); for pyramids, the minimum Jacobian at the 
apex is computed as the minimum of the 4 Jacobians when taking each 3 edge vectors out of 4, 

- L is the square root of the sum of the square lengths of all edges (or the edges used to calculate 
𝐽𝐽𝑚𝑚𝑚𝑚𝑚𝑚 for pyramid). 

Note that the approach to shape quality calculation in Griddle may differ from shape quality metrics 
calculation in Finite Element (e.g., ABAQUS, ANSYS, etc.) or Finite Volume (FLAC3D, 3DEC, etc.) software. 

The output log file uses the name of the Rhino project file (e.g., “RhinoProject.3dm”) and adds the 
following to the filename: “_GVol” + format type (Text/Binary, if applicable) + Output Format (e.g., 
“.f3grid”, “.inp”) + “.log” (e.g. “RhinoProject_GVol_Binary.f3grid.log”). The log is output to the same 
directory where the Rhino project is saved. 
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Griddle Utilities for Working with Surface Meshes 

GHeal – Tools for Surface Mesh Repair 

GHeal is a Griddle utility that can be used to identify certain surface mesh problems and fix them. In 
automatic mode, GHeal attempts to fix such issues as: patch mesh holes, patch (mend) cracks 
(elongated fissures on the external boundary of a surface mesh), clean clashing faces, remove small 
protrusions (a small number of mesh faces attached to the main mesh in non-conformal way), split non-
planar quadrilateral faces, align mesh normals, and clean (cull) redundant nodes and detached faces. 
Each of these operations are referred to as GHeal functions. In certain cases, running all these functions 
at once helps cleaning up and fixing a mesh. In other cases, only specific functions should be executed to 
clean up a mesh, as some other functions may distort the mesh or provide undesirable results. In 
general, GHeal functions (executed collectively or individually) often identify and clean mesh problems 
more efficiently than user efforts to fix a mesh manually or by using available Rhino tools. 

GHeal also has a Custom operation mode which calls Rhino’s command _MeshRepair. This command 
allows for more precise repairs of a mesh, e.g., patching a single hole where the user must select the 
boundary of the hole; GHeal’s AutomaticHeal operates on the whole mesh. It attempts to find all issues 
and repair parameters automatically. Refer to Rhino help documentation for more information about 
the _MeshRepair command. 

GHeal Options 

ShowErrors  
This option searches selected surface meshes for naked edges and clashing faces and plots traces of 
such edges and faces. 

Naked edges are face (or surface) edges that are not joined to other faces (or surfaces). In other 
words, only a single face (surface) shares/contains such edge. Mesh boundaries and discontinuities 
contain naked edges. They can also be found along disjointed faces and may not be visible (faces may 
appear to be connected that are not). 

Clashing faces are pairs of faces which are partially overlapping or intersecting in a non-conformal 
way. 

When clicking on this option, traces of naked edges are placed into the Rhino layer “NAKED_EDGES” 
and traces of the clashing faces are placed into the layer “CLASHING_FACES”. Examining polylines 
placed in these layers reveals potential mesh issues. 

Note that surface meshes within a watertight domain can have naked edges, for example, be partially 
connected to domain boundaries or “float” within the volume (also see information on GVol). 
However, the presence of naked edges on domain boundary meshes due to holes, disjointed faces, or 
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other discontinuities, as well as presence of clashing faces, usually indicates problems with surface 
meshes. Such problems must be addressed before volume meshing. 

CustomHeal 
This option calls Rhino’s command _MeshRepair, which checks meshes and fixes problems manually 
(one by one). Refer to Rhino help for the description of the _MeshRepair command. 

AutomaticHeal 
AutomaticHeal mode contains two options: IssuesToFix and Parameters. IssuesToFix specifies types of 
issues to work on and Parameters specify corresponding function parameters. They are described 
below in detail. 

IssuesToFix 
This option specifies types of issues (functions) that GHeal can operate on in AutomaticHeal mode. 
Any combination of the issues can be selected for GHeal to work on (by default all are selected). 
Every selected function is executed in the sequence it appears in the menu. 

All and None options allow to select all or deselect all issues in the list. 

FillHoles 
This function fills all holes within the selected meshes (Figure 26). The function uses the 
parameter MaxHoleArea, which is the maximum area of a hole to be filled. A hole will be filled if 
(i) the area of the hole is smaller than MaxHoleArea and (ii) the area of the hole is smaller than 
half of the total area of the entire mesh. Remeshing may be needed after filling large number of 
holes. 

  
Figure 26: GHeal’s function FillHoles fixes various holes in the surface mesh. Red lines show naked edges (left) and are 

provided for reference only in the right image. 

MendCracks 
This function mends (“stitches”) all cracks on the edges of the selected meshes (Figure 27). A crack 
differs from a hole by that it is connected to the external boundary of the mesh. The function uses 
the parameter MaxCrackOpening, which is the maximum distance between the edges of a crack. 
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Crack “stitching” starts at the tip of the crack and proceeds as long as (i) the opening angle at the 
crack tip is <= 90° and (ii) the maximum distance between the edges of the crack is smaller than 
MaxCrackOpening. Remeshing may be needed after fixing large cracks. 

  
Figure 27: GHeal’s function MendCracks “stitches” a crack on the boundary of a surface mesh. Red lines indicate 

naked edges (left) forming the crack and are provided for reference only on the right image. 

FixClashingFaces  
This function fixes clashing mesh faces (faces which intersect or overlap) within each selected 
mesh (Figure 28). FixClashingFaces uses logic similar to GInt but intersects/splits faces locally in 
each mesh. FixClashingFaces will not fix non-conformal and overlapping faces from different 
intersecting meshes. To properly intersect distinct meshes, use the mesh intersector GInt. 

  
Figure 28: GHeal’s function FixClashingFaces locally intersects/splits clashing faces. 

Note that in certain cases functions FillHoles and MendCracks may introduce clashing faces if 
newly built faces intersect with existing faces. Using FixClashingFaces together with these 
mentioned functions helps resolve this problem. Remeshing may be needed after fixing clashing 
faces. 

RemoveProtrusions  
This function removes mesh faces (patches) protruding from the main surface of the mesh. An 
example of such protrusion is shown in Figure 29. The function uses the parameter 
MaxProtrusionPerimeter, which is the maximum perimeter of the protruded mesh patch. The 
protruded mesh patch will be removed if it is joined to the rest of the mesh in non-manifold 
manner and if (i) the total perimeter of the protruded patch is smaller than 
MaxProtrusionPerimeter or (ii) there are two or less faces in the protruded mesh patch. 
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Figure 29: GHeal’s function RemoveProtrusions removes a single face which “sticks out” from the main mesh. 

SplitNonPlanarFaces 
This function splits non-planar quadrilateral faces into pairs of triangular faces. The non-planar 
quadrilaterals are divided along the short diagonal. 

CullRedundancies 
This function culls unused mesh points and degenerated faces and combines points that are too 
close to each other. The function uses the parameter MaxNodeDistance, which is the maximum 
distance between two mesh nodes below which the nodes will be considered coincident.  

AlignNormals 
This function aligns normals in each component of the mesh and it works on compound meshes 
consisting of joined/welded sub-meshes. This function is more robust than Rhino's 
_UnifyMeshNormals command when working with compound meshes. 

Parameters [ = Automatic (default), Custom] 
This option allows specifying parameters for the functions selected in the IssuesToFix menu. 
Parameters = Automatic automatically calculates and uses optimal parameters for the functions 
listed above. Parameters = Custom allows user to manually specify parameters for GHeal’s 
functions. Possible options are: 

MaxHoleArea [value > 0, default = 1] 
This parameter defines, in model units, the maximum area of a hole to be filled. 
MaxCrackOpenning [value > 0, default = 0.01]  
This parameter defines, in model units, the maximum distance between the edges of a crack in 
model units.  
MaxProtrusionPerimeter [value > 0, default = 0.1] 
This parameter defines, in model units, the maximum perimeter of the protruded mesh patch in 
model units.  
ToleranceMultiplier [value 0.001-1000, default = 0.1] 
This parameter defines the multiplier for the minimum edge length found among all clashing 
faces. Clashing faces are intersected in each cluster using GInt algorithm, and intersection 
tolerance is calculated as tolerance = multiplier x minEdgeLength. 
MaxNodeDistance [value > 0, default = 0.001] 
This parameter defines the tolerance or the maximum distance between two mesh nodes below 
which the nodes will be considered coincident. Model units are used.  
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GExtract – Tools for Extraction of Surface Meshes 

GExtract is a Griddle utility that allows extracting parts of surface meshes based on user-specified 
criteria. As surface meshes approximating real engineering and geological structures may be rather 
complex, there is often a need to extract (or separate) parts of the meshes either to remove them or to 
assign specific properties in preparation for volume meshing. GExtract has five different modes of 
operation to assist with that. 

For the first two modes described below, GExtract extracts faces based on a break angle and whether to 
stop the extraction at non-manifold edges (a common edge that is shared by more than 2 faces). In 
these modes, the command is similar to Rhino’s command _ExtractConnectedMeshFaces, except the 
GExtract utility allows for a consistent manner of selecting faces of non-manifold meshes and stopping 
only if the angle exceeds the break angle and/or at non-manifold edge. 

GExtract Options 

SingleSurface 
In this mode GExtract extracts single manifold sub-mesh containing a selected face. When using this 
mode, user first must select a mesh face from which the rest of the selection will propagate (Figure 
30). After that a dialog will be shown (Figure 31, Figure 32) that requests criteria for stopping 
selection. When the user clicks OK, all the selected faces will be separated as a new mesh (mesh 
properties will match the original properties). 

 
Figure 30: Selecting an initial face for GExtract’s SingleSurface extraction mode. 

The Non-Manifold Extract Faces dialog sets two criteria for stopping selection: 
• By a break angle (Max break angle: 0-180°) or  
• when the selection hits a non-manifold edge (Break at non-manifold edges). 

The first option specifies the angle between joined faces (in degrees). Specifying 0° will only select 
joined faces that are coplanar with the face picked. If the second option is disabled, GExtract will 
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propagate its selection of faces at non-manifold edges to those faces having the smallest angle with 
the currently processed faces (i.e., GExtract will follow the smoothest path at non-manifold edge). 

The second option allows stopping the selection at non-manifold edges. Figure 31 and Figure 32 show 
the results when breaking at non-manifold edges is enabled or disabled. 

 
Figure 31: Face selection in the case where Break at non-manifold edges is enabled. 

 
Figure 32: Face selection in the case where Break at non-manifold edges is disabled. 

AllSurfaces 
This mode extracts all possible manifold sub-meshes from selected surface meshes. This option 
specifies break angle only (0-180°). The extraction of sub-meshes occurs when either angle between 
neighboring faces exceeds the specified break angle or if a non-manifold edge is encountered. Note 
that initial faces are picked automatically; the user does not need to pick any faces. 

The example in Figure 33 and Figure 34 shows the use of AllSurfaces mode with break angle 60°. A single 
non-manifold conformal mesh (Figure 33) is split into multiple manifold conformal meshes (Figure 34). 
Afterwards, the extracted meshes are assigned different colors using the ColorizeObjects tool. 
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Figure 33: Initial single non-manifold conformal mesh (some internal meshes are not visible). 

 
Figure 34: The result of application of GExtract with AllSurfaces mode to the initial mesh. 

When using AllSurfaces mode, the angle between faces is calculated using the angle between face 
normals. Therefore, it is important that all mesh normals are aligned to have proper mesh extractions. 
If mesh extraction leads to unexpected results, align mesh normals using GHeal’s AlignNormals 
function or Rhino’s _UnifyMeshNormals command (it may not work properly for compound/joined 
meshes). 

BoundaryFaces  
This mode extracts only those faces that are attached to naked edges (i.e., mesh boundaries). 
Extracted faces are combined into a separate mesh that is assigned the same layer and name as the 
original mesh but a different color. This option can operate on multiple meshes simultaneously. An 
example of extraction of boundary faces from two meshes is shown in Figure 35. 
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Figure 35: Extraction of boundary faces using GExtract’s BoundaryFaces mode. 

NonManifoldFaces  
This mode extracts only those faces that are attached to non-manifold edges if any are present in the 
mesh. Extracted faces are combined into a separate mesh that is assigned the same layer and name as 
the original mesh but a different color (Figure 36). The option can operate on multiple meshes 
simultaneously. This option may be used to refine a mesh around non-manifold edges by using the 
surface remesher GSurf (for example, (i) assign a custom element size to the extracted mesh and 
remesh everything or (ii) specify hard edges along extracted mesh boundaries using the _DupBorder 
command and then remesh only the extracted mesh). 

 
Figure 36: Extraction of faces attached to non-manifold edges using GExtract’s NonManifoldFaces mode. 

SurfacesWithinSolid  
This mode extracts pieces of meshes that are located within specified closed volume solids (e.g., a box, 
cylinder, etc.) Extracted mesh pieces have the same properties as the original meshes but are assigned 
a slightly different color. After the operation completes, extracted mesh pieces are selected so it is 
easier for the user to do other operations with them (e.g., hide, delete, move, remesh, etc.) It is 
advisable to keep the solids in a separate layer(s), so they can be easily hidden while keeping the 
extracted meshes selected (for example, to hide the solids, switch layers containing them to 'off'). The 
option can operate on multiple meshes simultaneously and can use multiple solids. This option may be 
used to change element size in extracted meshes by using surface remesher GSurf (for example, (i) 
assign custom element size to extracted mesh parts and then remesh everything or (ii) specify hard 
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edges along the extracted mesh boundaries _DupBorder command and then remesh only the 
extracted mesh parts). 

Figure 37 shows an example of extraction of sub-meshes located within a cylinder (the solid). The 
cylinder is represented as BRep object, and it is not a mesh. First, user must select all meshes to 
process and then select the solid. After GExtract finishes operation, the extracted meshes are 
highlighted (top-right image). If the cylinder was placed into a separate Rhino layer, it can be easily 
hidden from the view by turning off the corresponding layer. The extracted meshes stay selected 
(bottom-left image). At this point user may change properties of the selected meshes or do other 
operations with them. 

 
Figure 37: Process of extraction of mesh faces located within a solid by using GExtract’s SurfacesWithinSolid mode. 
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GExtend – Tools for Surface Mesh Extension  

GExtend is a Griddle utility that allows extending a surface mesh by adding new faces to it. New mesh 
faces are created along a selected part of the mesh boundary or along the whole boundary. After that 
they can be joined to the original mesh or kept as a separate mesh (the original mesh is not changed). 
GExtend has several options when building new faces: (i) building new faces in the average tangent 
direction calculated using orientation of the initial mesh faces at the selected part of the boundary, (ii) 
building new faces along user-specified vector, and (iii) building new faces in “free” direction (in this 
mode user can drag-and-drop the boundary piece on the screen to set the final position). 

One of the important parameters of GExtend is the extension length, which specifies edge size for newly 
built faces (along the extension direction). The extension length should be comparable to the size of 
faces in the initial mesh at the selected part of the boundary. If the extension length is significantly 
larger than the typical initial face/edge size, the extended mesh may be of poor quality or even be 
invalid due to the requirement of preserving average tangent.  

After using the _GExtend command, remeshing of the extended surface mesh may be necessary to 
improve mesh quality and to achieve desired element size.  

GExtend has three modes of operation: ExtendSelectedBoundary, ExtendAllBoundaries, and FreeExtend. 
For the first two modes, the command extends the boundary by a given distance while the third mode 
allows the user to do “free” extension of the selected boundary by moving it to any location.  

When extending a mesh along a part of the mesh boundary, all mesh boundaries are highlighted in 
purple for easier selection (Figure 38). With boundaries highlighted, the user selects a desired region as 
shown in Figure 38. Additional pieces of the boundary can be added (or removed) by pressing and 
holding Shift (Ctrl) and the left mouse button. Make sure to select a continuous piece of the boundary 
as GExtend operates on single continuous segment of the boundary. 

 
Figure 38: GExtend highlights mesh boundary in purple and allows selecting a piece of the boundary (in yellow). 
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GExtend Options 

ExtendSelectedBoundary 
In this mode, GExtend extends the mesh along the selected part of mesh boundary by a given distance 
(Figure 39). Three parameters should be specified for the operation to begin: 

ExtendLength 
This parameter specifies, in model units, the extension length. It is the same as the edge length of 
newly built faces in the extension direction. 
MeshType [= Merged (default), Separated] 
This parameter specifies if the newly built (extended) mesh patch should be merged with the initial 
mesh or kept separate. 
Direction [= LocalTangent (default), AlongVector] 
This parameter specifies the extension direction along which new faces are constructed. If 
LocalTangent is selected, new faces are constructed along average local tangent vector calculated at 
the nodes of the selected boundary part. If AlongVector option is used, the extension direction can 
be specified by typing the coordinates of vector's starting and ending points. Alternatively, as the 
command shows all mesh vertices, the user may select any point as the start and/or the end of the 
extension vector (in general, any two points can be chosen to specify the extension vector). 
 

       

Figure 39: Extension of a mesh along part of its boundary using ExtendSelectedBoundary mode. 

ExtendAllBoundaries 
This mode expands the initial mesh(es) along all its boundaries by a given distance (Figure 40). 
Multiple meshes can be selected and boundaries of each mesh will be extended. The options in this 
mode are the same as in ExtendSelectedBoundary mode. 
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Figure 40: Expansion of a mesh along all its boundary using ExtendAllBoundary mode. 

FreeExtend 
This mode extends a mesh at a selected part of the boundary to a custom position by moving 
(dragging and dropping) the selected part (Figure 41). The movement starts at a node in the middle of 
the selected part and stops at a point where user “drops” it. The extended part of the mesh is merged 
with the initial mesh. 

 

 

Figure 41: Process of selecting and dragging a part of a mesh boundary using FreeExtend mode.  
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GExtrude – Tools for Surface Mesh Extrusion 

GExtrude is a Griddle utility that allows extruding a surface mesh to a bounding surface to create a 
watertight mesh domain. The extrusion is done along the mesh external boundary and follows these 
steps. 

1. Project each node on the boundary of the initial surface mesh onto the bounding surface (using 
shortest distance). 

2. Connect the projected nodes to each other and to the corresponding original nodes to form side 
surfaces. 

3. Mesh the side surfaces. 
4. Fill the area within the projected boundary on the bounding surface with a mesh. 

This approach of mesh extrusion onto a bounding surface is designed to quickly create a watertight 
modeling domain from a given surface mesh (e.g., a topographic mesh). It works well when the 
bounding surface is planar or nearly planar. The approach is not designed for exact mapping of the initial 
surface mesh onto a bounding surface and it does not guarantee that mesh projection will exactly 
conform to the bounding surface if it is non-planar. The approach requires that the initial surface mesh 
is simply connected— meaning it cannot contain holes, naked edges, or internal boundaries (check mesh 
quality and fix issues with GHeal, if needed).  

GExtrude has three basic options: ExtrdMeshType, MeshOutput and MeshMode. Several additional 
options vary depending on the MeshMode. 

GExtrude options 

ExtrdMeshType [= Tri (default), QuadDom] 
This parameter specifies the type of surface mesh used in the extruded mesh: Tri produces an all-
triangle surface mesh, QuadDom produces a quad-dominant surface mesh (contains a mix of triangles 
and quadrilaterals). 

MeshOutput [= Merged (default), Separated] 
This parameter specifies if the extruded mesh should be merged with the initial mesh into a single 
mesh object or kept separate. 

MeshMode [= Unstructured (default), Structured] 
This parameter specifies the mode of the output mesh. When it is set to Unstructured mode, two 
additional parameters will display: 

MinEdgeLength, MaxEdgeLength. 
These parameters control the resulting minimum and maximum edge size in the final surface mesh. 
To get uniform sizes, minimum and maximum edge size can be set to the same value. Edge size is 
specified in model units. It is important to set non-zero minimum edge length to get a good quality 
output mesh. 
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Figure 42 demonstrates how the command extrudes a surface mesh onto a bounding surface when 
MeshMode = Unstructured. 

         
Figure 42: The initial mesh and bounding surface (left) and the results of mesh extrusion to form a watertight domain. 

When MeshMode is set to Structured, an additional option StructuredParams appears: 

StructuredParams [=FixNumberElements (default), FixEdgeLength] 
If FixNumberElements is chosen, the number of elements along the extrusion direction is fixed and is 
defined by the option NumElements, which the user must specify. 
If FixEdgeLength is chosen, the element length along the extrusion direction is fixed and is defined 
by the option EdgeLength, which the user must specify. 

Figure 43 demonstrates the results of the extrusion when MeshMode = Structured and 
StructuredParams = FixNumberElements (left image) and when StructuredParams = FixEdgeLength 
(right image). 

          
Figure 43: Results of mesh extrusion when using Structured mode and fixing the number of elements (left) or the edge 

length (right) along the extrusion. 
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Joining Non-Manifold Surfaces 

_NonManifoldMerge is a Rhino command that joins several manifold or non-manifold surfaces and 
polysurfaces into a single non-manifold polysurface6. It is provided in Griddle for convenience as it can 
be used in the process of preparing surface meshes for volume meshing. 

Starting with surfaces or polysurfaces that fully connect along one or more edges (as in Figure 44), a 
single polysurface can be created with the NonManifoldMerge tool. This polysurface can later be 
meshed using _Mesh command resulting in a fully conformal non-manifold mesh with all parts of the 
mesh being properly attached, as opposed to the case of meshing multiple surfaces separately. Now the 
mesh intersection step (as in Figure 16) may be skipped and the user may continue with remeshing the 
initial mesh (with GSurf) and then creating a volume mesh (with GVol). 

This procedure avoids problems related to using improper tolerance during the mesh intersection step 
(GInt) and thus obtains accurate results faster. However, the drawback of this approach is that the 
output surface mesh is now a single object (it can be split using GExtract). A simple example of such 
procedure is shown in Figure 44 and a detailed example is provided in Griddle 2.0 Tutorial Examples. 

 

 

Figure 44: Three step process to create a single mesh out of multiple surfaces/polysurfaces. 

Note that in certain cases Rhino’s _Mesh command may not generate initially conformal mesh from a 
single complex polysurface created with _NonManifoldMerge command. This may happen in cases 
when the _NonManifoldMerge is applied to (poly-)surfaces that protrude through each other rather 
than connecting along the edges (as in Figure 44). 
  

 
6 In this context, manifold means that a surface edge is shared by at most two surfaces. In contrast, consider two 
intersecting planar surfaces and represented as a single polysurface object. Now the edge along the intersection 
line is connected to 4 sub-surfaces. Thus, the whole polysurface object will be non-manifold. 
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Colorizing Objects 

In general, all newly created objects in Rhino get the color of the active Rhino layer. To differentiate 
objects from each other by color, select several objects in Rhino and click on the ColorizeObjects icon to 
assign different (random) colors to each selected object (Figure 45). To revert to a colorization by layer, 
select objects, open the Properties tab (press F3), and in the item labelled Display Color, select Display 
Color → By Layer. 

          
Figure 45: Various objects before and after ColorizeObjects is applied. 
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Group Names Assignment 

Groups in FLAC3D and 3DEC 
FLAC3D and 3DEC can associate names with volume elements (zones, blocks) and names or numbers 
with faces (face groups, joint ids). These named entities make it easier to reference areas of the model 
for material or boundary condition assignment. 

The volume meshers GVol and BlockRanger deal with groups in a slightly different manner. 

• GVol, when generating a volume grid, requires a closed set of boundary surface meshes. The 
inside can be composed of “floating” surfaces, i.e., surfaces that are partially or completely 
disconnected from other surfaces. Because Rhino only operates with surface meshes and not 
volumes, it is not immediately clear if a set of input surface meshes encloses a watertight 
volume. For this reason, volumes cannot be directly named; only surfaces can be named. 

• BlockRanger requires solids as input. There is no ambiguity about what is inside or outside a 
solid. For this reason, BlockRanger can name solids. BlockRanger does not allow “floating” 
surfaces and surfaces in BlockRanger do not use names. 

GVol Generated Groups – FLAC3D 
A hypothetical section through a Griddle volume mesh generated for FLAC3D is shown in Figure 46. After 
filling the interior of the model domain with zones (elements), Griddle assigns an ID to each watertight 
volume. Figure 46 presents an example of such volume IDs as large white numbers. The IDs are used to 
generate group names for zones in FLAC3D. 

Zones 
FLAC3D zone groups are always assigned names automatically based on volume ID (as Rhino currently 
does not have capabilities to interact with volumes represented by surface meshes). To distinguish zone 
groups from other group names, Griddle assigns zone groups the prefix “ZG_” and a suffix corresponding 
to the closed volume ID. For, example, area 1 in Figure 46 can be referenced as “ZG_001” in FLAC3D. The 
“ZG_” groups are stored in slot “SLOT 1”. 

Zone faces 
Zone faces (represented by the thick black and red lines below) are placed in face groups. Face groups 
can be assigned automatically based on volume IDs or, if faces belong to a named surface, surface name 
is used. All face groups are placed in slot “SLOT 1”. 

Griddle creates external face groups with the prefix “EF_” and internal face groups with the prefix “IF_”. 
When surface name is not present (assigned automatically), names of external face groups are 
appended with the single volume ID to which the faces are attached. Similarly, internal face groups are 
appended with a combination of two volume IDs representing the two groups on either side of the faces 
(the larger number is always placed second in the name). If the Rhino surface mesh has a name, then 
this name is always used. 
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Some surfaces do not fully divide the volume into distinct pieces. Such “floating” surfaces are 
represented by the red lines in Figure 46. In automatic naming, their face group names contain a 
duplicate number. For example, faces group “IF_002_002” is designated from the “ZG_002” zone groups 
on either side of it. 

Using Provided Surface Names 
If the surface mesh has a name assigned to it in Rhino Properties, then this name will be used for 
FLAC3D face group (and prefixed with “EF_” or “IF_”). These names take precedence over the 
automatically assigned names shown in Figure 46. 

 
Figure 46: Zone and face groups from a Griddle-generated FLAC3D grid for automatic group name assignment. 

GVol Generated Groups – 3DEC 
Blocks 
3DEC block groups are represented by strings containing numeric digits. Block groups start at “001” for 
3DEC_7.x output and at “10001” for 3DEC 5.2 (due to 3DEC 5.2 specifics) and each new group name is 
increased by “1”. Block groups are assigned in random order. For example, block group names will be 
“001”, “002”, … (similar to FLAC3D “ZG_…” groups, see Figure 46). All groups are placed in “SLOT 1”. 

Joint group names 
Joint groups are also represented by strings with integers. All external faces and joints within each group 
of rigid blocks are typically associated with IDs/groups “1” and “2”, and they are not output by GVol. 
GVol outputs joint groups starting from names “3”, “4”, “5”, … which are given to the surfaces 
separating various blocks (for BlockType = Deformable) or block groups as well as “floating” surfaces (for 
BlockType = Rigid). All groups are placed in “SLOT 1”. 

Joint groups are arbitrarily assigned if corresponding surface mesh name is not provided (there is no 
relationship between joint group and the block group names surrounding it). Note that “floating” 
surface meshes (the red lines in Figure 46) will not appear in 3DEC deformable output and therefore no 
names would be assigned to them. 
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3DEC also allows assigning a separate group name to joints. If a surface mesh has a name assigned to it 
in Rhino Properties, then this name will be output as the joint group name. 

BlockRanger-Generated Groups – FLAC3D 
BlockRanger solids can be named in two ways: through the layer name that the solid belongs to and 
through the solid Properties Name field (Figure 47). The layer Name is used to generate zone group 
names for FLAC3D in “SLOT 1”. The Properties Name is used to generate zone group names for FLAC3D 
in “SLOT 2”. 

The white text names in Figure 48 and Figure 49 are assumed to be Rhino layer names. In Figure 48, the 
black text prefixed with “ZG_” indicates “SLOT 1” zone groups. The yellow text indicates “SLOT 2” zone 
groups. “SLOT 2” group names are automatically generated if the Properties Name field is left blank. A 
Rhino layer name cannot be blank. Example internal (“IF_” prefix) and external (“EF_” prefix) face group 
names are also shown in Figure 48. Note, a face group is not generated for the seam between the two 
bedrock solids or the seam between the two soil solids shown in Figure 48. 

  
Figure 47: Naming solids by layer (top) and through the Properties Name field (bottom). 

BlockRanger Generated Groups – 3DEC 
For 3DEC 5.2, BlockRanger uses the layer name as the 3DEC block group name (Figure 49). For example, 
the Rhino layer “soil” would result in a 3DEC block group called “soil”. 3DEC 7.x output uses block 
numbering similar to FLAC3D and does not use layer names. For either version of 3DEC, all block groups 
are placed in “SLOT 1”. Internal faces which separate different named layers are assigned joint set IDs 
starting from 2, as in Figure 49. 
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Figure 48: Zone and face groups from a BlockRanger-generated FLAC3D grid. 

 

 
Figure 49: Block groups and joint set IDs from a BlockRanger generated 3DEC model. 

Note: GVol and BlockRanger replace all occurrences of whitespace characters (blanks, tabs, etc.) in 
name fields with an underscore character “_” to avoid string interpretation problems in FLAC3D and 
3DEC. Names are case insensitive, e.g. “Upper_Rock” is treated as the same name as “upper_rock”. 

Group Names in Other Formats 
When outputting in other formats (e.g. ANSYS, NASTRAN, etc.) no groups are assigned except for 
ABAQUS output in which: 

• GVol assigns automatically generated names for element groups in watertight volumes in the 
format: “G10001”, “G10002”, etc. 

• BlockRanger assigns names to element groups according to Rhino layer names. 
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Importing Griddle Volume Meshes 
Griddle’s volume meshers BlockRanger and GVol output volume meshes into a text or binary file in the 
format corresponding to the selection of a numerical simulation software, such as FLAC3D, 3DEC, 
ABAQUS, etc. The list below provides general tips on importing mesh files into corresponding software 
(note that workflow in the users’ version of the software may differ from what is present below): 

• FLAC3D: Navigate to menu File → Grid → Import from FLAC3D… and open the mesh file 
(*.f3grid) or use the ”zone import” command.  

• 3DEC 7.0 or newer: Navigate to menu File → Grid → Import from 3DEC…  
or File → Grid → Import from Griddle… and open the mesh file (*.3dgrid) 
or use the ”block import” command. 

• 3DEC 5.2: Navigate to menu File → Open Item… and select Data File: Call. Then locate and open 
the mesh file (*.3ddat) containing commands to generate the grid. 

• ABAQUS: Workflow is provided for Abaqus/CAE. Navigate to menu File → Import → Model → 
Abaqus Input File (*.inp,…) and open the mesh file (*.inp) 

• ANSYS: Workflow is provided for ANSYS Workbench. Importing depends on how the volume 
mesh is generated: 
o For GVol generated meshes, navigate to menu File → Import and select the mesh file 

(*.cdb). 
Within the Project Schematic window, double click on Setup to open the External Model 
window. Within the Properties of File pane, uncheck the checkbox “Check Valid Blocked CDB 
File”. 
Navigate back to the Project Schematic window and right-click on Setup and select Update, 
which will import the mesh. 

o For a BlockRanger generated mesh, first run script from ANSYS Workbench on the output 
file by navigating to menu File → Scripting → Run Script File. Within the Scripts folder, 
select the ConvertAnsysFileToCdb.py script and open the mesh file (*.cdb) to convert 
it from the old-style format to a blocked CDB file. 
Once the file is converted, navigate to menu File → Import to import the converted CDB file. 
Within the Project Schematic window, right-click on Setup then Update, which will import 
the mesh. 

• LS_DYNA: Workflow is provided for LS-PrePost. Navigate to menu File → Import → LS-DYNA 
Keyword File, select All Files in the file filter, and open the mesh file (*.lsdyna970). 

• NASTRAN: Workflow is provided for MSC-Patran. Navigate to menu File → Import → Source: 
MSC.Nastran Input and open the mesh file (*.bdf). 
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Introduction 
The tutorial examples provided in this document are designed to familiarize Griddle users with the 
principles of Griddle operation, workflows, and typical Rhino commands that allow the creation of 
structured and unstructured volume meshes suitable for numerical analysis. 

The examples presented in the tutorial are not designed to illustrate exact (or even realistic) engineering 
models and conditions. However, they provide the basis on which Griddle users can build their 
knowledge for working with complex engineering models. 

All the examples were developed in Rhino 6, but identical (or very similar) operations, commands, and 
workflows can be done in later versions of Rhino. 

When working on the examples from the tutorial, periodically save the model in order to return to it if 
needed. Rhino provides a useful file saving feature, called Incremental Save (accessible from the top 
menu: File → Incremental Save). 

Refer to the Griddle User Manual to find more information about Griddle commands and options, and 
the Rhino help system (top menu Help or F1) for Rhino operations. 

 

The files corresponding to the tutorial examples can be accessed from the Windows Start Menu → 
Itasca Griddle 2.0 → Griddle 2.0 Tutorial Files link. Clicking on the link opens user writable directory 
ProgramData\Itasca\Griddle200 (typically on drive ”C:”) which contains the documentation and 
the tutorial material. Users can directly work in this directory. A reserve copy of the same material can 
be found in the Documentation subfolder of Griddle installation location (typically in C:\Program 
Files\Itasca\Griddle200). 
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Tutorial 1: A Single Cylinder 
Expected work time: 0.5 – 1 hour 

This tutorial provides information on how to create unstructured and structured meshes for a simple 
cylinder using Griddle’s GVol and BlockRanger volume meshers. Before proceeding with meshing, a 
cylindrical geometry is created, and this process differs depending on which volume mesher will be 
used. 

Generating unstructured mesh with GVol 
1. Open Rhino, and when the Templates splash screen appears, select Small Objects, Meters. The 

same can be done by navigating to File → New from the Rhino top menu. 
2. Save the Rhino project at a desired location. 
3. Type the _Cylinder command or select the Solid → Cylinder menu item. Type 0 and press Enter to 

set the location of the center of the cylinder base at the origin. Next, set the radius of the base to 2. 
Enter 10 for the height of the cylinder. Press Alt+Ctrl+E to zoom out all viewports to the extent of all 
objects (or navigate to View → Zoom → Zoom Extents All). This completes construction of the 
geometry for a simple vertical cylinder (Figure 1). 

 
Figure 1: Solid representing a cylinder 

The watertight geometry created in the previous steps can be referred to as a cylindrical solid. A solid is 
a closed surface that defines a volume with a clear interior and exterior. The next step is to triangulate 
the cylinder surface to create the initial triangular mesh. 

4. Select the cylinder and type _Mesh in the Rhino command prompt. If the Polygon Mesh Detailed 
Options dialog window opens, click on the Simple Controls… button in the lower-right corner of the 
window to open a simplified dialog. 

5. In the simplified dialog, move the slider all the way to the right towards More polygons and click OK 
to create the initial surface mesh (Figure 2). 
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Figure 2: Original highlighted cylindrical surface and the newly created surface mesh superimposed on it. 

6. While the original cylindrical surface is still highlighted (seen in light yellow in Figure 2), type the 
_Hide command to hide it, making only the surface mesh visible. This triangular surface mesh serves 
as input to Griddle tools for unstructured meshing. 

7. Select the surface mesh and type _GSurf or click on the  icon in the Griddle toolbar to remesh 
the initial triangular mesh. Select Mode = QuadDom, MinEdgeLength = 0.5, MaxEdgeLength = 0.5 
and keep all other parameters at the default values. The resulting mesh is shown in Figure 3. 

 
Figure 3: Quad-dominant surface mesh generated by _GSurf. 

8. Select the surface mesh generated in the previous step and type _GVol or click on the  icon in 
the Griddle toolbar. Select MeshSettings → Mode=HexDom, leave all other parameters at the 
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default settings and press Enter twice. After the Save As dialog appears, type a desired name for the 
output file. GVol will generate a conformal hex-dominant volume mesh and output it using the 
FLAC3D binary format (the default format) to the selected file. This file can be imported into FLAC3D 
using FLAC3D’s File → Grid → Import from FLAC3D … option (Figure 4). 

 
Figure 4: Volume mesh of cylinder imported into FLAC3D. 

Although the mesh in Figure 3 and Figure 4 may resemble a structured mesh or a pure hexahedral mesh, 
the GVol output log file reports that the output mesh contains: 

number of elements: 
  total: 1433 
  hexahedra: 1072 (74.81% of total, 94.04% of volume) 
  prisms: 67 (4.68% of total, 2.63% of volume) 
  pyramids: 187 (13.05% of total, 2.62% of volume) 
  tetrahedra: 107 (7.47% of total, 0.71% of volume) 

This report confirms that the output mesh is hex-dominant as it was selected in GVol options. Note that 
users may get slightly different results with regard to the number of elements of each type (this also 
depends on the particular version of Griddle). 

Generating structured mesh with BlockRanger 
BlockRanger is Griddle’s all-hex structured volume mesher, and it operates using different principles 
than the unstructured mesher GVol. As such, BlockRanger operates only on four-, five-, or six-sided 
solids (not surface meshes). The cylinder created in the previous section is not such a solid as it contains 
only three distinct sides. Therefore, to create a structured mesh for the cylinder, the initial solid must be 
subdivided into several pieces suitable for BlockRanger. There are different ways of accomplishing this 
task; the most commonly used is described below. 
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1. Open Rhino, and when the Templates splash screen appears, select Small Objects, Meters. The 
same can be done by navigating to File → New from the Rhino top menu. 

2. Save the Rhino project at a desired location. 
3. Double-click on Top viewport to maximize it. 
4. In the Rhino command prompt, type the following commands to create the initial curves: 

• _Line → Start of line = 1,1 → End of line = -1,1 
• _Line → Start of line = 1,1 → End of line = 2,2 
• _Line → Start of line = -1,1 → End of line = -2,2 
• _Arc → Center of arc = 0 →Start of arc = 2,2 →End point or angle = -2,2 

When creating an arc, make sure that the mouse cursor stays above the previously created lines, 
so the arc goes through the top portion of a circle (Figure 5). 

 
Figure 5: Creating an arc between two points. 

5. Select all lines with Ctrl+A and type the _Join command to create a single polyline as in Figure 6. 

  
Figure 6: Single polyline consisting of three lines and an arc. 

6. While the polyline is selected, type the _Rotate command and click on Copy=Yes 
• Center of rotation = 0 



Griddle v2.00.14, Tutorial Examples, rev112423  8 

• Angle of first reference point = 90 (Enter) 
• Angle of first reference point = -90 (Enter) 
• Angle of first reference point = 180 (Enter) 
• Press Enter 

7. Type _Polyline and proceed with: 
• Start of polyline = 1,1 
• Next point of polyline = -1,1 
• Next point of polyline = -1,-1 
• Next point of polyline = 1,-1 
• Next point of polyline = 1,1 

8. Select all 5 objects and type _ColorizeObjects in the command prompt (or click on the  icon in 
the Griddle toolbar). The command will assign a random color to each object (Figure 7). 

  
Figure 7: Five colorized polylines (some edges overlap). 

9. Switch to Perspective viewport by clicking on the icon under the viewport. 
10. Select all objects and type the _ExtrudeCrv command and set Extrusion distance = 10. 
11. Delete the original polylines while they are selected. 
12. Select all objects (should be 5 polysurfaces) and type the _Cap command to close them and create 

watertight solids. 
13. Select all and type the _ColorizeObjects command. 

The resulting five solids represent a cylinder, but each solid is topologically equivalent to a rectangular 
prism. All these solids are suitable for BlockRanger. 

14. Select all objects (or type the _SelPolysrf command to select only polysurfaces). 

15. Type _BR or click on the  icon in the Griddle toolbar and specify only GenerateSurfaceMesh = 

BySolid to visualize the faces on the external and internal boundaries of the solids. Set MeshSettings 
→ MaxEdgeLength = 0.85. The output volume mesh will be outputted by default in FLAC3D binary 
format. 



Griddle v2.00.14, Tutorial Examples, rev112423  9 

  
Figure 8: A cylinder subdivided into 5 solids (Ghosted view). 

16. Type the _SelPolysrf command to select only polysurfaces and delete them.  

The resulting surface mesh is provided in Figure 9 and it shows high quality quadrilateral faces on the 
boundaries. Note that BlockRanger produces a single mesh; for better representation, the mesh in 
Figure 9 was split into several submeshes (using GExtract tool) which were colorized (with 
ColorizeObjects tool). 

  
Figure 9: Surface mesh corresponding to the generated volume mesh (Ghosted view). 

The output file with a volume mesh can be imported in FLAC3D. The zone plot will show five grouped 
regions composed of a structured pure hexahedral mesh (Figure 10). Note that for this simple extruded 
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geometry, users can use the FLAC3D Extruder to produce similar results. However, BlockRanger may 
operate on rather complex 3D solids, which will be shown in further tutorials. 

  
Figure 10: A cylinder subdivided into five solids (Ghosted view). 
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Tutorial 2: Vertical Shaft Excavation in a Stratified Soil 
Expected work time: 0.5 – 1 hour 

This tutorial shows an example of constructing the geometry and mesh for a vertical shaft (150 ft deep, 
diameter of 30 ft) that is to be excavated in stages. The shaft is constructed in two-layered soil with the 
surface separating the soil layers located at a depth of 50 ft (Figure 11). The model domain is 
represented as a cube 200 ft × 200 ft × 235 ft. Each excavation stage is 10 ft deep; therefore, there are 
15 stages as shown by the red circular pattern in Figure 11. 

 
Figure 11: A general view of the model of a vertical shaft in a stratified soil. 

Generation of analytical geometry 
1. Start Rhino, select Large Objects, Feet (similar method as step 1 in Tutorial 1) and save the Rhino 

project at a desired location. 
2. Select or maximize Perspective viewport and switch to Shaded view. 
3. Create a cylinder by typing the _Cylinder command and specify Base of cylinder = 0, Radius = 15, End 

of cylinder = -10. 
4. Create a line by using the _Line command from 0,0,-10 to 0,0,-150. 
5. Select the cylinder and type the _ArrayCrv command. Then select the line and, in the pop-up dialog, 

set the Number of items to 15 and keep Orientation as Freeform; press OK. The command will copy 
the initial 10 ft deep cylinder multiple times to create the desired 15 stages of excavations. 

6. Type the _SelCrv command to select the curve and delete it. 
7. Verify that 15 stages were created by selecting everything in the viewport (Ctrl+A); the command 

area should display the message: 
15 extrusions added to selection. 

8. Create three points that will define the plane separating two layers of soil by using the _Point 
command. For the coordinates, specify: 
• -100,-100,-50 
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• 100,-100,-50 
• 100,100,-50 

9. Connect all points by a horizontal plane by typing the _Plane command and start dragging a plane 
from one of the “side” points (the first or third in the list above). The objects should look as shown 
in Figure 12. 

  
Figure 12: Construction of a shaft and a plane separating two layers of soil 

10. Select and delete points using the _SelPt command. 
11. Create a domain box by typing the _Box command (or select in the menu Solid→Box→Diagonal) 

and click on the Diagonal option to define the box by 2 points. Enter -100,-100,-235 for the 
coordinates of the first point and 100,100,0 for the second point.  

12. Switch to Wireframe view and zoom to all extents if needed (Alt+Ctrl+E). 
13. Select all objects and type the command _NonManifoldMerge (or click on the   icon in the 

Griddle toolbar) to create a single non-manifold polysurface. This complex polysurface will serve as 
the initial geometry for meshing. 

  
Figure 13: Complete initial geometry of the model of a shaft and two soil layers. 
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Meshing with unstructured mesh 
The geometry created in the previous step is ready for meshing. 

14. Select all objects and type the command _Mesh. If a simplified dialog appears, click on the Detailed 
Controls… button and enter the values as shown in Figure 14. 

  
Figure 14: Rhino meshing dialog to create an initial mesh. 

15. While the polysurface is still selected, hide it with the _Hide command. If it is not selected, select it 
with the _SelPolysrf command. Only the mesh should be visible at this point. 

16. Select the surface mesh and type _GSurf or click on the  icon in the Griddle toolbar to remesh 
the initial triangular mesh. Select Mode = QuadDom, MinEdgeLength = 4, MaxEdgeLength = 20 and 
keep all other parameters at the default values. The resulting mesh is shown in Figure 15. 

  
Figure 15: Rhino meshing dialog to create the initial mesh. 
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The surface mesh in Figure 15 looks good and rather symmetric despite the fact that this is an 
unstructured mesh. GSurf was able to create such a mesh due to simple symmetric geometry and the 
choice of meshing parameters. In general, however, unstructured meshes are rarely symmetric. 

17. Now the model is ready for volume meshing. To show how the volume meshing parameters 
influence the final mesh, two cases are considered here. 

• Select the surface mesh and type _GVol or click on the  icon in the Griddle toolbar. Select 
MeshSettings → Mode=HexDom, leave all other parameters at the default settings and press 
Enter twice. Keep the output format as FLAC3D Binary. 

 
The resulting FLAC3D grid is shown in Figure 16. The grid is of good quality, but the soil layers 
have a noticeably sharp change in zone size closer to the shaft. This can be improved by varying 
the GVol parameters. 

  
Figure 16: FLAC3D grid of the shaft model when using default GVol parameters. 

• Create a new volume mesh using the following GVol parameters: 
MeshSettings → Mode=HexDom, MaxGradation=1, TargetSize=5, Optimization=10, 
ShapeQuality=1. For the explanation of each parameter, refer to the Griddle 2.0 User Manual. 
The resulting mesh is shown in Figure 17. 
 
The grid surrounding the shaft in Figure 17 has many more zones, and the transition from coarse 
to finer zones is more gradual. Typically, such results are achieved when MaxGradation is set to 
a small value (< 0.5), but in this case, as the domain boundaries are relatively close to the shaft, 
a larger value of MaxGradation has to be used to force the mesher to quickly change from a 
large zone size on the boundary of the domain to a finer size specified by the TargetSize. Use of 
the highest possible values for Optimization and ShapeQuality allows for improving zone quality. 
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Figure 17: FLAC3D grid of the shaft model when using custom GVol parameters. 

Excavation of the shaft can be modeled by gradual removal of the stages inside the shaft (i.e., zone 
groups ZG_003 – ZG_017 as in Figure 16 and Figure 17). 
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Tutorial 3: Meshing a Model with Analytical Surfaces 
Expected work time: 1 hour 

This tutorial describes two meshing approaches for a model containing analytical objects, such as Rhino 
(poly)surfaces and solids defined by NURBS (non-uniform rational basis spline), SubD (high-precision 
Catmull Clark subdivision surfaces; only in Rhino 7 and later) or BRep (boundary representation). 

1. Open project “T3_BridgeSupport.3dm” located in folder “TutorialExamples\3_BridgeSupport”. 
Create a copy of this initial project with a different name at a desired location (use File → Save As). 

2. The model represents a part of a complex bridge support structure as shown in Figure 18. The model 
consists of 13 surfaces, seven polysurfaces, and two extrusions represented by BRep objects. Note 
how the objects are split by each other (e.g., the top light blue surface is split in three pieces); this is 
done for better meshing results. 

 
Figure 18: Model of a bridge support structure. 

The typical approach to construct meshes when starting with initial (poly)surfaces such as in Figure 18 
consists of the following:1 

• Mesh (triangulate) all the (poly)surfaces to create initial rough meshes; if initial meshes are 
provided, this step is skipped. 

• Intersect the initial meshes with Griddle’s surface mesh intersector GInt.  
• Remesh all meshes with surface remesher GSurf. 
• Create volume mesh with unstructured volume mesher GVol. 

Users should follow this general approach in the majority of cases. However, in certain situations, a 
slight variation of this approach may be more efficient in preparing the model for volume meshing. The 
standard approach is described in the first sub-section of this tutorial, and potential issues are outlined. 

 
1 See also Griddle 2.0 User Manual, Section “Using Griddle Tools for Unstructured Meshing”. 
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The second sub-section presents a variation of the approach, which can be applied to models similar to 
the one described in this Tutorial. 

Mesh generation using GInt and GSurf (approach 1) 
3. Maximize Perspective viewport and switch to Shaded view for better visibility. 
4. Navigate to the Layers pane and create a new layer “Meshes_Approach1”. If the pane is not visible, 

it can be opened from Edit → Layers → Edit Layers…. 
5. Select all objects (Ctrl+A) and type the _Mesh command to create the initial mesh of all objects. Use 

detailed controls with the following settings to construct a fine initial mesh (Figure 19). 

  
Figure 19: Rhino meshing dialog to create fine initial mesh. 

6. While all the (poly)surfaces are selected, invert the selection by typing the command _Invert, which 
will select meshes only. Navigate to the Properties pane (or press F3) and change the mesh layer to 
“Meshes_Approach1”. Open the Layers pane and turn off the “Surfaces” layer (click on the 
lightbulb). 

  
Figure 20: The initial Rhino mesh. 
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The mesh in Figure 20 is not conformal and contains gaps along the curved boundaries (Figure 21). This 
is due to fact that surface meshes are a discrete representation of the initial analytical (in this case, 
BRep) surfaces, and the mesh for each object is created independently from any other objects. The gaps 
and non-conformal faces can be fixed by intersecting meshes using the GInt surface mesh intersector 
with a properly selected tolerance. Having a watertight surface mesh domain is a required condition for 
volume meshing. At the same time, making all model meshes fully conformal is usually needed but is not 
always required for volume meshing (e.g., separate watertight domains must contain conformal surface 
meshes but the domains themselves may be non-conformal in the areas of contact). 

  
Figure 21: Mismatching mesh boundaries in the initial Rhino mesh. 

In certain cases, it may be challenging to determine a proper tolerance value when intersecting many 
meshes. This is especially true for big models with large variations in face (element) sizes and with 
gaps/mismatches between neighboring faces that are of similar size as some of the mesh faces. The 
reason for this challenge is that a small GInt tolerance may not be sufficient to close the gaps and 
intersect all the faces to make them conformal, while a large tolerance may create undesired 
intersections and changes of smaller faces that fall within the tolerance. Therefore, it is recommended 
to do mesh intersections with minimal acceptable tolerance to avoid creating incorrect intersections. 
Users may need to do several trials starting with 0 tolerance and gradually increase it until all faces are 
properly intersected. This process is outlined below. 

7. Select all surface meshes and type _GInt or click on the  icon in the Griddle toolbar. For the first 
trial, keep Tolerance = 0, and click on AdvancedParameters. By default, GInt preserves initial mesh 
shapes and other parameters, which is set by the option OutputMesh = Separated. In this case, the 
output mesh needs to be merged to clearly identify if there are any gaps or non-conformal faces 
between the meshes. Click on OutputMesh to set it to Merged2. Press Enter twice to execute GInt. 

 
2 When setting OutputMesh = Merged, GInt intersects all selected surface meshes and creates a single merged 
mesh assigned to the default (current) layer. Merged meshes have a smaller number of boundary edges and allow 
for easy identification of holes, gaps, or non-conformal faces within the mesh. 
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8. To check if there are any gaps or non-conformal edges/faces left, select the output mesh and type 

_GHeal or click on the  icon in the Griddle toolbar. Select the ShowErrors option, which will 
create two new layers, “NAKED_EDGES” and “CLASHING_FACES”, containing outlines of open mesh 
boundaries (e.g., internal holes) and non-conformal faces. The results show that there is a large 
number of gaps and some non-conformal faces (Figure 22 and Figure 23). This is because GInt 
Tolerance was set to 0 to intersect only those mesh faces that are in full contact. Naked edges can 
also be visualized with Rhino’s _ShowEdges command. 

  
Figure 22: Naked edges (in pink) and clashing faces (red) after using GInt with Tolerance = 0. 

  
Figure 23: Zoomed naked edges (in pink) after using GInt with Tolerance = 0. Compare with Figure 21. 

9. Undo the last two commands (_GHeal and _GInt) by pressing Ctrl+Z twice. Ensure the initial _Mesh 
command is not undone. 
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10. Select all initial surface meshes and run GInt again. This time specify Tolerance = 0.005 and keep all 
other parameters the same as in the previous run. After GInt executes, visualize naked edges and 
clashing faces as outlined previously in step 8. The results show that there are still some naked 
edges and clashing faces (Figure 24), which indicates that GInt Tolerance is still not sufficient. 

  
Figure 24: Naked edges (in pink) and clashing faces (red) after using GInt with Tolerance = 0.005. Compare with Figure 22. 

11. Repeat steps 9 and 10 using Tolerance = 0.015. The output mesh does not have naked edges or 
clashing faces, which means that all faces from distinct meshes were properly intersected. To see 
this, _Hide the mesh and select all objects (Ctrl+A). Rhino should report that no objects are selected. 

12. Undo the last operations (_Hide/_Show, _GHeal, _GInt) by pressing Ctrl+Z until the initial Rhino 
mesh is shown as in Figure 20. 

13. Run GInt again with Tolerance = 0.015 and OutputMesh = Separated (in AdvancedParameters). Note 
that this time all distinct meshes are preserved, and it would be hard to check for naked edges as 
each mesh has its own boundary. That is why a merged mesh was used in the previous steps. 

14. Select all surface meshes and remesh with GSurf (  ) using the following parameters: Mode = 
QuadDom, MinEdgeLength = 0.25, MaxEdgeLength = 5, RidgeAngle = 5, AdvancedParameters → 
MaxGradation = 0.06, and keep all other parameters at the default values. The resulting meshes are 
shown in Figure 25. These meshes look good overall, but zoomed views of the curved bottom / top 
embankment sections reveal (yellow-green mesh) that these areas contain small elements (faces) 
that do not fully conform to the initial shape (Figure 26). This is due to independent meshing of the 
initial BRep surfaces and due to using a large tolerance in GInt3. 

 
3Another potential issue can be revealed by completing step 14 with OutputMesh = Merged. The single output 
mesh may contain a few overlapping (clashing) faces that were introduced by GSurf. However, these clashing faces 
do not affect the ability to create a volume mesh, as they are between separate watertight sub-domains. In 
general, clashing faces within a single mesh can be fixed using GHeal’s FixClashingFaces function, which locally 
intersects them. 
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15. Create a volume mesh using GVol (  ) and any desired (or default) parameters. GVol 

automatically checks input surface meshes for the presence of naked edges (e.g., holes, gaps) and 
clashing (non-conformal) faces to assure that input meshes create a watertight domain; if any such 
issues are found, an information message is shown. The message does not prevent GVol from 
running (click Yes to proceed); it is only a reminder for users to verify that input meshes are valid. In 
this case, GVol input consists of multiple surface meshes with boundaries treated as naked edges.  
 
The initial error check and the message can be turned off by setting IniErrorCheck to No (in GVol’s 
MeshSettings options). 

  
Figure 25: Remeshed surface meshes using standard approach. 

  
Figure 26: Slightly deformed surface meshes when using standard approach. 
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Mesh generation using NonManifoldMerge and GSurf (approach 2) 
The issues in the previous approach can be avoided if all initial (poly)surfaces are merged into a single 
non-manifold polysurface before meshing. The initial meshing (triangulation) of all connecting surfaces 
within a single object happens in a conformal manner, and no gaps are created between mesh faces. 
Therefore, with this approach, surface mesh intersection is often not needed. The drawback of this 
approach is that when the initial objects are merged into a single non-manifold polysurface, user-
specified object information is lost (e.g., surface names, colors, etc.). However, if these parameters are 
not important, the approach outlined below may be much easier, more efficient, and yield better quality 
meshes. 

16. Navigate to the Layers pane and create a new layer named “Meshes_Approach2”. Turn on layer 
“Surfaces” to show the initial surfaces. 
Delete layers (if any) “NAKED_EDGES”, “CLASHING_FACES”, and “MESHING_ERRORS”. 

17. Select all objects in layer “Surfaces” (as in Figure 18) and use command _NonManifoldMerge (  ) 

to create a single non-manifold polysurface (Figure 27). The new polysurface is placed into the 
current layer (“Default”); move it back to the “Surface” layer by changing the object layer 
assignment in the Properties pane (F3). 

  
Figure 27: Single polysurface constructed by the NonManifoldMerge command. 

18. Mesh the polysurface using the _Mesh command with the same settings as in Figure 19. Note that 
the default mesh settings and Simple Controls can be used in this case, as there will be no issues 
with gaps or non-conformal faces (there is no need to have a highly detailed initial mesh). 

19. Assign layer “Meshes_Approach2” to the newly created mesh and turn off the “Surface” layer so 
only the mesh is present in the viewports. 

20. Remesh the initial mesh with GSurf (  ) using the same settings as in Step 14. The quality of 
elements (faces) around the curved parts of the embankment is much higher if compared with the 
mesh in Figure 25 (or with the meshes in layer “Meshes_Approach1”). 
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21. Verify that there are no naked edges (gaps, holes) or clashing faces in the final surface mesh using 

GHeal (  ) → ShowErrors. There should be no curves outlining any problems in layers 
“NAKED_EDGES” and “CLASHING_FACES”. 

  
Figure 28: Remeshed surface mesh in the second approach. 

22. The mesh is ready for volume meshing. Run GVol (  ) with any desired (or default) parameters. 

Due to the higher quality of input surface mesh(es), the total number of elements in the output 
volume mesh is smaller in this approach than in the previous one (e.g., for Hex-dominant mesh, this 
approach produces in total ~47,000 elements and the first approach results in ~69,000 elements). 

As mentioned previously, the issue of this approach is that all initial (poly)surfaces must be merged into 
a single nonmanifold polysurface before meshing. If there is a need to assign a name, color, or any other 
property to a specific surface mesh before volume meshing, the merged surface mesh can be easily split 
into sub-meshes using Griddle’s tool GExtract. 

23. Select the merged surface mesh (as in Figure 28) and type the _GExtract command or click on the 

  icon in the Griddle toolbar. Select option AllSurfaces and use MaxBreakAngle = 180 to separate 
meshes only along non-manifold edges (the break angle will not have an effect as it is set to 180°). 
Alternatively, if break angle = 89° is used, all meshes that connect at an angle > 89° will also be 
separated (thus, meshes that are perpendicular to each other will be separated). 

24. Select all (36) meshes and use Griddle’s command _ColorizeObjects or click on the  icon in the 
Griddle toolbar. This will assign a unique color to each Rhino object (Figure 29). 

25. Now a name can be assigned to each surface mesh if there is a need to transfer surface mesh names 
into a volume mesh (available only for FLAC3D and 3DEC output formats in GVol). 
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Figure 29: Mesh from Figure 28 “exploded” into sub-meshes, which are subsequently colorized. 
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Tutorial 4: Creating a Structured Mesh with BlockRanger 
Expected work time: 1–2 hours 

This tutorial provides detailed information on how to build a block-structured hexahedral mesh from an 
initial CAD model provided by a DXF file. To create a mesh using BlockRanger (_BR command), an 
assembly of six-, five-, or four-sided Rhino solids that conform to the reference model must be created. 
The creation of such an assembly is the objective of this example. The reference model is shown in the 
left side of Figure 30. The final hexahedral mesh is depicted to the right. This 3D slope model has a 
shape similar to a bathtub; hence, it is sometimes referred to as the “bathtub” model. 

      

Figure 30: Reference model (left) and BlockRanger generated mesh (right). 

Importing the geometry 
1. Start Rhino, select Large Objects, Meters (similar method as step 1 in Tutorial 1) and save the Rhino 

project at a desired location. 
2. Import the initial geometry from a DXF file by navigating to File → Import and select 

“T4_3DSlope.dxf” located in folder “TutorialExamples\4_StructuredMesh_SlopeModel”. In the 
Import dialog, select Model → Meters and Layout Units → Millimeters, and keep other parameters 
at the default values. 

3. Maximize Perspective viewport and make sure Shaded view is selected. 
4. In the top menu, navigate to View → Display Options… This will open the Rhino Options dialog; 

select View → Display Modes →Shaded → Objects → Curves and set Curve Width to 4. This will 
display all curves thicker in the Shaded view. The initial settings can be always restored by clicking 
on Restore Defaults. 

5. Navigate to the Layers pane as shown in Figure 31. If the pane is not visible, open it by going to 
Edit→Layers→Edit Layers… In the Layers pane, rename the automatically created layer “lines” to 
“Reference” and delete all layers except “Default” and “Reference”. Ensure that all objects are now 
in layer “Reference” by selecting all objects and navigating to the Properties pane (or press F3). 

6. Select all objects and type the command _Move. For the Point to move from, select the bottom-left 
corner of the model and for the Point to move to, type 0. This will move all objects and align the 
bottom-left corner of the model with zero coordinates. Compare the results with Figure 31. 

It is always recommended to move/center objects imported from a DXF (or other formats) closer to zero 
coordinates as it improves the accuracy of Rhino operations. 
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Figure 31: The reference model. 

Choosing the right mesh block layout for the model 
BlockRanger operates on solids and meshes each solid block individually. The present model may be 
decomposed into solid blocks in many ways. Some of the possible options are shown in Figure 32 
through Figure 35. The arrangement of blocks depicted in Figure 34 will be used in this tutorial. 

Each of the blocks shown in Figure 32 through Figure 35 satisfy BlockRanger requirements for solids, 
which includes the following: 

• Permissible types of solids: 
o four-sided solids made of three-sided faces (a topological tetrahedron); 
o five-sided solids made of two three-sided faces connected through three four-sided 

faces (a topological triangular prism); and 
o six-sided solids made of four-sided faces (a topological hexahedron). 

• Faces must be simple faces that cannot be further “exploded” into simpler faces. 
• Face edges must only be simple curves that cannot be further “exploded” into simpler curves. 

 

Figure 32: Solid layout resulting in five mesh blocks. 
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Figure 33: Solid layout resulting in six mesh blocks. 

 

Figure 34: Solid layout resulting in eight mesh blocks. 

 

Figure 35: Alternate solid layout resulting in nine mesh blocks. 
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Building solids from curves 

7. Click on Osnap (Object Snap) at the bottom of the screen (Figure 36) to highlight it. Make sure that 
all checkboxes designating what to snap to are checked, as shown in Figure 36. Grid Snap may be 
turned off. 

 
Figure 36: Rhino status bar. 

8. Starting with the reference model presented in Figure 31, create new construction lines as shown in 
Figure 38. Use the _Line command and start by connecting nodes from the middle of the model 
(where the curved segments are) to the sides of the model. Pay attention to when the mouse tooltip 
shows “Perp” or “Perp, Int” (or other types of intersections), which means that the line under 
construction is perpendicular to (and intersects) another line. 

 
Figure 37: Creating new construction lines (in black). 

The curves created in the previous step (Figure 31) are polylines, and some of them are composed of 
multiple linear segments that cannot be used directly to build surfaces. They must be retraced with arcs 
(Curve → Arc) or higher order curves (Curve → Free-Form → Interpolate Points) to create simpler two-
noded curves. 

9. Zoom in around the curved segments in the model and select in the top menu Curve → Arc → Start, 
Point, End. Create separate arcs at each curved segment of the model as shown in Figure 38 and 
Figure 39. In total, four arcs should be created. Pay attention to when the mouse tooltip shows 
“End, Int, Knot” when connecting to the points in the middle of the curved segments. Such a tooltip 
means the mouse is at the end of a line, hit an intersection with another line, and is at a knot. 

10. After the arcs are created, the initial polylines that have been retraced can be deleted. 
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Figure 38: Building the upper (top) and lower (bottom) arcs. 

 
Figure 39: Red arcs retrace the original polylines at the curved section of the model. 

11. Select the bottom two arcs and copy them using the _Copy command. For Point to copy from, select 
the left corner of the arcs as shown in Figure 40, then, within command options, click on Vertical to 
set it to Yes, and drag the corner down until it hits the bottom line and the mouse tooltip is as in 
Figure 40. 

   
Figure 40: Copying the arcs. 
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12. Connect the middle nodes as shown in Figure 41 with the dark blue line. Connect the bottom end of 
the dark blue line to the opposite corner as shown in Figure 41 with the light blue line. 

 
Figure 41: Connecting the middle ends of the arcs (blue lines). 

13. Split all intersecting lines (mostly those from the reference model) by using the _Split command. For 
this, first select the line to split and then select a line that intersects or connects to it. For example, 
the tan line at the bottom of Figure 41 can be split in three pieces by the connecting black lines. The 
resulting wireframe should contain 56 curves (Ctrl+A and check the number of selected objects) and 
is the basis for creating solid blocks (Figure 42). 

 
Figure 42: Model wireframe ready to be used for block creation. 

14. Start creating a block at the top-left side of the model. Select the two arcs and two lines as shown in 
Figure 43 (selected lines are in yellow), type the _Loft command and use the settings shown in the 
right side of Figure 43. Click OK to build a lofted polysurface between the several curves. 
Alternatively, a single surface can be built between each pair of curves/lines. 
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Figure 43: Building the surfaces for the first solid. Note that the grid has been hidden on this image. 

15. Now, select only pairs of lines/curves composing the remaining surfaces of the first solid and _Loft 
them. In total, six sides must be created as in Figure 44. 

     
Figure 44: Building surfaces of the first solid. 

16. Select all newly created surfaces and a polysurface and join them with the _Join command. This is 
the first solid block. Hide it with the _Hide command, as it will be easier to create other solids when 
nothing obstructs the view. 

17. In the same manner, build all other solid blocks except for the small central block, as it requires an 
additional operation (described below). The stages are outlined in Figure 45. 
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Figure 45: Building solid blocks for the model. 

  
Figure 46: Building the last solid block in the model. 
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18. For the remaining central block, build only vertical surfaces using the _Loft command and join all 
four of them with the _Join command (Figure 46, left). 

19. Select a single polysurface as in Figure 46, left and cap the holes with the _Cap command (Figure 46, 
right). The resulting solid is the last block needed before meshing. 

20. Show all blocks that were previously hidden with the _Show command. There should be eight solid 
blocks as in Figure 47. 

  
Figure 47: Solid blocks of the model (Ghosted view). 

21. Select all curves by typing the _SelCrv command and assign layer “Reference” to them (navigate to 
Properties pane or press F3). Hide this layer in the Layers pane (press on the lightbulb to turn it off). 

22. Select all remaining objects with Ctrl+A and verify that Rhino reports only eight polysurfaces have 
been selected. If any surfaces are reported, this is an indication that they were not joined to a solid 
block. Find and join them so that only eight closed polysurfaces (solids) are present. While the solids 
are selected, navigate to the Properties pane (or press F3) and ensure that object Type indicates that 
they are closed polysurfaces (Figure 48). If the Type field says “varies”, most likely it means that 
some solids are not closed (probably incorrect surfaces were created). 

23. Create new layers “Upper solids” and “Lower solids” in the Layers pane. Assign distinct colors to 
these layers. Select only upper solids and assign them to the layer “Upper solids” (through the 
Properties pane). Complete the same for the lower solids (Figure 49). 

Now all solids are ready for meshing. 
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Figure 48: Solid blocks of the model (Ghosted view). 

 
Figure 49: The model after the “Upper solids” and “Lower solids” layers have been specified. 

 

Meshing with BlockRanger 

24. Select all solids and type the _BR command or click on the  icon in the Griddle toolbar. Use the 

default BlockRanger parameters and save the mesh in FLAC3D binary format. 

In the Rhino command area, BlockRanger should report: “8 solids processed, 8 solids meshed, 0 errors.” If 
any of the solids do not satisfy the BlockRanger requirements outlined previously, the corresponding 
solids will remain highlighted in Rhino and BlockRanger will report that it processed less than 8 solids. 



Griddle v2.00.14, Tutorial Examples, rev112423 35 

Figure 50 shows a structured FLAC3D grid created by BlockRanger, as well as Zone groups from SLOT1. 
SLOT2 groups correspond to the original solid blocks and are shown in Figure 51. 

 
Figure 50: In Rhino, solids organized in layers are processed into FLAC3D groups in SLOT1. 

 
Figure 51: FLAC3D SLOT2 groups correspond to the individual Rhino solids. 

 

As an additional exercise, change the BlockRanger meshing parameters and observe how the output 
mesh changes. For example, try setting MaxEdgeLength = 3.0 or MaxEdgeLength = 100.0 and 
MinEdgeResolution = 5. The simplest way to check the results is by generating bounding surface mesh 
with GenerateSurfaceMesh option. Use different choices in the option and observe how it changes the 
bounding surface mesh. The ByModel choice results in surface mesh on the boundary of the whole 
model only, selecting ByLayer adds faces the boundary between layers, and selecting BySolid adds faces 
on the boundaries between each solid.  
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Tutorial 5: Creation of a Hybrid Structured-Unstructured Mesh 
Expected work time: 1–3 hours 

This tutorial describes a methodology that can be used to create hybrid volume meshes consisting of 
structured and unstructured meshes. This methodology ensures that both types of meshes are perfectly 
connected and fully conformal. 

Structured meshes often provide high-quality elements and conform better to desired mesh parameters 
(such as element size, type). These meshes, however, can typically be created only for regular shape 
objects, for example, man-made structures. On the other hand, unstructured meshes can fill objects of 
any shape and are well suited for meshing irregular geologic features. In this example, a tunnel 
excavation is filled with a structured mesh produced by BlockRanger, while the surrounding rock 
domain containing irregular topographic and fault surfaces is filled with an unstructured mesh. 

Importing the geometry 
1. Start Rhino, select Large Objects, Meters (similar method as step 1 in Tutorial 1) and save the Rhino 

project at a desired location. 
2. Import the initial geometry from a DXF file by navigating to File → Import and select 

“T5_geometry.dxf” from folder “TutorialExamples\5_HybridMesh_Tunnel”. In the Import dialog, 
select Model → Meters and Layout Units → Millimeters, and keep other parameters at the default 
values. 

3. Maximize Perspective viewport, select Shaded view, and zoom out to the extent of the model by 
pressing Ctrl+Alt+E. 

4. In the top menu, navigate to View → Display Options… This will open the Rhino Options dialog; 
select View → Display Modes →Shaded → Objects → Curves and set Curve Width to 4. This will 
display all curves thicker in the Shaded view. The initial settings can always be restored by clicking 
on Restore Defaults. 

  
Figure 52: DXF geometry imported to Rhino corresponding to the tunnel profile and excavation direction. 
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5. Navigate to the Layers pane and delete all layers except for “Default”, “Direction”, “Topo”, “Fault”, 
and “TunnelProfile”. 

The imported geometry contains two meshes, one corresponding to the topographic surface and one 
corresponding to a large fault. Note that the fault almost reaches to the topo surface but does not 
intersect it. This will need to be fixed, as the fault is supposed to intersect the surface. The geometry 
also contains a horseshoe-shaped curve (in blue) corresponding to the tunnel profile and a red curve 
corresponding to the tunnel excavation direction. The tunnel must be constructed along the red curve in 
such a way that its cross-section is always perpendicular to the curve. Note that the front end of the red 
curve is already aligned with the bottom-left corner of the tunnel profile. 

Construction and meshing of the tunnel with structured mesh 
6. Turn off layers “Topo” and “Fault” to leave only the profile and direction curves visible. 
7. Tunnel profile consists of several curves (in blue). Select all of them and type _Join. 
8. Select the red curve (excavation direction) and type the command _Sweep1. For cross-section 

curves, select the single blue curve (tunnel profile). When offered to Drag seam point to adjust, drag 
it from the bottom-left corner of the tunnel profile to the topmost point of the profile and press 
Enter (maximize Front viewport for ease of dragging the seam point; this can be done while the 
command is active; Figure 53). It is important to move the seam point from the corner to create the 
proper geometry suitable for BlockRanger. For other options in the _Sweep1 command, use those 
shown in Figure 54. 

  
Figure 53: Drag seam point to the top of the tunnel profile. 

9. Create new layer “Tunnel” and assign a newly created tunnel surface to it. 
10. Select the tunnel profile curve (blue) and create the tunnel cross-section surface out of it by using 

the command _PlanarSrf. 
11. Select the initial cross-section surface and use command _ArrayCrv to duplicate it along the 

direction path (red curve) with a spacing of roughly 5 m; this will create excavation stages that can 
be gradually removed during numerical simulations (Figure 55). In the command options pop-up 
window, set Distance between items = 5, Orientation = Freeform. 

12. Turn off layers “TunnelProfile” and “Direction” as they will no longer be needed. 
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Figure 54: Creation of tunnel surface by sweeping the profile curve along the direction path. 

  
Figure 55: Creation of excavation stages by duplicating initial cross-section surface. Tunnel surface is not shown. 

13. Split the tunnel surface with all the cross-section surfaces by selecting the tunnel surface only, then 
using the _Split command and selecting all other surfaces (Ctrl+A). A message stating that “One 
polysurface split into 21 pieces.” should appear in Rhino’s command area. 

14. Turn off layer “Tunnel”. Only the tunnel cross-sections should be visible. Delete all of them (21 
objects). 

15. Turn the “Tunnel” layer back on. Select all 21 polysurfaces and use the _Cap command to close the 
front and back of each excavation stage. A Rhino notification should appear that 42 caps have been 
created. Now each excavation stage is represented by a separate watertight polysurface (or by a 
solid), which can be easily meshed using BlockRanger. 

16. Colorize all stages with Griddle’s _ColorizeObjects command (Figure 56). 

Before proceeding with meshing the tunnel, some additional work is needed to trim parts of the tunnel 
that extend past the boundaries of the model. 
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Figure 56: Watertight polysurfaces (solids) representing each excavation stage of the tunnel. 

17. Turn off the “Tunnel” layer and turn on the “Topo” layer to show the topographic surface mesh. 
18. Create a planar surface underneath the topo mesh by using the _Plane command and selecting the 

Center option to specify the center of the plane and its size. 
• Center of plane: 0,50,-25 
• Other corner or length: 150 
• Width: press Enter 

19. Select the topo mesh and duplicate its border using the _DupBorder command. 
20. Select the border curve and extrude it downward using the _ExtrudeCrv command in such a way 

that all parts of the extrusion go below the plane (Figure 57). This will create a polysurface that 
intersects the horizontal plane. Delete the duplicated border. 

  
Figure 57: Extrusion of topographic surface border. 
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21. Select the extruded polysurface and split it by the horizontal plane using the _Split command. 
Delete the bottom piece of the polysurface. 

22. Select the planar surface and split it by the remainder of the extruded polysurface. Delete the outer 
piece of the planar surface. 

23. Join the bottom surface with the extruded polysurface (_Join command) to create a closed domain 
(together with the topo mesh), which will serve as the modeling domain after meshing. 

24. Create new layer “Domain” and place the newly created polysurface in it (by changing the layer 
assignment in the polysurface properties). 

25. Turn on the “Tunnel” layer and note that the front and back sections of the tunnel stick out from the 
domain (Figure 58). Split them by the domain and delete excessive parts. 

  
Figure 58: The front part of the tunnel extends through the modeling domain. 

26. Hide layers “Topo” and “Domain” so only the tunnel stages are present. 
27. Now the front and the back of the tunnel contain openings. Select the front and back tunnel stages 

and cap them using the _Cap command to create watertight solids. At this point, the tunnel is ready 
for meshing. 

28. Select all 21 solids corresponding to the tunnel excavation stages and type the _BR command or 
click on the  icon in the Griddle toolbar. Use all default BlockRanger parameters and set 
GenerateSurfaceMesh = ByModel. BlockRanger will create a structured volume mesh for the tunnel 
and will output it at the user-specified location (keep FLAC3D binary format as output format). 
BlockRanger will also create surface mesh corresponding to the tunnel’s external surface and will 
output it into Rhino (Figure 59). This surface mesh will be used to create an unstructured volume 
mesh outside the tunnel. 

29. Create new layer “TunnelMesh”. Change the layer of newly created surface mesh from “Default” to 
“TunnelMesh”. Now turn off layer “Tunnel”, leaving only one layer active as shown in Figure 59. 
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Figure 59: Surface mesh corresponding to the exterior of the tunnel’s structured volume mesh. 

Meshing the tunnel exterior with unstructured mesh 
To create an unstructured domain mesh that is conformal with the tunnel structured mesh, bounding 
surface mesh presented in Figure 59 will be used. 

30. First, the front and back caps of the bounding surface mesh should be removed to leave only the 

“shell” of the tunnel. Type the _GExtract command or click on the  icon in the Griddle toolbar. 
Select option AllSurfaces and use MaxBreakAngle = 85° to separate the caps. Select and delete them 
afterwards. The tunnel mesh should be hollow inside. 

31. In the Layers pane, right-click on layer “TunnelMesh” and select Duplicate Layer and Objects. The 
next few steps will cause changes in the tunnel mesh, but volume meshing (the final step) requires 
the original mesh. Therefore, the duplicated tunnel mesh is used in the next steps. Turn off layer 
“TunnelMesh” and keep the duplicated layer on. 

32. Select the tunnel mesh and use the command _DupBorder to duplicate its open boundary. 
33. Turn on layer “Domain”. Select the domain polysurface and split it with the duplicated tunnel 

boundaries by typing the _Split command and selecting the curves only. 
34. Delete parts of the domain corresponding to the tunnel front and back to create openings for the 

tunnel (Figure 60). 
35. Select the domain and create the initial mesh for it using the _Mesh command. Use Simple Controls 

and select the middle position with the slider. While the polysurface is still selected, delete it. The 
initial mesh is not very good, but it will be remeshed in future steps. 

36. Turn on the “Fault” layer. Note that the fault does not fully intersect the domain and the topo 
meshes (turn “Topo” layer on and off to see that). To extend the fault mesh to the domain 
boundaries, select it and type the _GExtend command or click on the  icon in the Griddle 

toolbar. Select option ExtendAllBoundaries, specify ExtendLength = 10, and keep MeshType = 
Merged. The command will extend the mesh by adding new faces, and the extended mesh will fully 
intersect the domain and topo meshes. Turn on the “Topo” layer. The result should look similar to 
Figure 61. 

37. Select all objects with Ctrl+A and use GInt to intersect all meshes. Use a tolerance of 0.001 and keep 
all other parameters at defaults. 
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Figure 60: Removing parts of the domain at tunnel front and back. 

  
Figure 61: Extended fault mesh intersects domain and topo meshes. Note that the colors of topo and tunnel meshes and 

duplicated tunnel borders (curves) are changed from default. 

38. Delete the copy of the tunnel mesh (blue mesh in Figure 61) or delete the whole layer containing it. 
39. Select all objects again with Ctrl+A and use GSurf to remesh the meshes. Because the duplicated 

tunnel borders are selected as well (red curves in Figure 61), they will serve as hard edges to 
preserve conformity with the tunnel mesh. Use the following parameters for GSurf: Mode = 
QuadDom, MinEdgeLength = 1, MaxEdgeLength = 10, RidgeAngle = 40, and keep all other 
parameters at default values. 
After GSurf completes remeshing, the duplicated tunnel borders stay selected. Delete them, as they 
are no longer needed (Figure 62). 
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Turn on layer “TunnelMesh” and zoom in to the tunnel front or back (Figure 63). It can be easily seen 
that both tunnel and domain meshes are conformal (nodes and edges match along the border). This is 
due to using GInt to create proper initial intersections between the domain and tunnel meshes and due 
to using the border of the original tunnel mesh as a hard edge during remeshing. 

  
Figure 62: Result of remeshing of all meshes (except for the tunnel mesh) while preserving mesh edges and nodes along the 

tunnel borders (hard edges). 

  
Figure 63: Close view of the tunnel front showing that tunnel and domain meshes are conformal. 
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40. Assign names to each of the meshes in the object Properties pane (click on a mesh and press F3), 
e.g., name fault “Fault”, tunnel mesh - “Tunnel”, etc. These names will be passed as surface names 
within the volume mesh. 

Now the model is ready for volume meshing with GVol. Even though parts of the fault mesh extend 
outside the watertight domain, volume meshing can be carried out. GVol typically marks parts of surface 
meshes causing meshing errors with red outlines; in this case, however, red outlines will simply indicate 
that the “external” mesh faces were ignored during the meshing process. 

41. Select all meshes and use GVol to create an unstructured volume mesh for the exterior of the 
tunnel. For parameters, use HexDom mesh and output in FLAC3D binary format; keep all other 
parameters at defaults. Save the output file at the same location as the tunnel structured mesh (do 
NOT overwrite it). Note that the volume mesh will not be created inside the tunnel this time, as the 
interior part of the tunnel is not a watertight domain; only the exterior of the tunnel constitutes a 
watertight domain. 

Two meshes (grids) have been created in this example: a structured volume mesh with stages 
corresponding to the interior of the tunnel and an unstructured volume mesh corresponding to the 
exterior of the tunnel (domain). Both meshes can be loaded in FLAC3D (or any other code, if another 
format was used) and used for numerical modeling. Because the meshes are conformal and faces, 
edges, and nodes are duplicated along the boundary of the tunnel, FLAC3D can merge the meshes to 
avoid using attach conditions. After importing both meshes, use the merge command: 

flac3d>zone gp merge 
--- 2610 gridpoints merged and 5160 surface faces removed. 

The result is shown in Figure 64. 

  
Figure 64: Structured and unstructured meshes loaded in FLAC3D.  
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Tutorial 6: Mesh Clean-up and Rebuilding 
Expected work time: 1 hour 

This tutorial provides an example of a model that requires initial mesh cleaning and fixing before further 
model operations can be done. The model provided as a DXF file contains an existing triangular surface 
mesh defining drifts in a mine and a topographical surface (Figure 65). Such surfaces often come from 
minimally processed field measurements by various surveillance systems, and they often consist of 
triangular meshes, which generally are not clean (often non-conformal, contain overlapping and 
duplicate faces, missing faces, etc.) Thus, they typically need to be cleaned and remeshed to produce 
surface meshes suitable for volume meshing. 

 
Figure 65: Drift geometry from a mine. 

Importing the geometry 
1. Start Rhino, select Large Objects, Meters (similar method as step 1 in Tutorial 1) and save the Rhino 

project at a desired location. 
2. Import the initial geometry from a DXF file by navigating to File → Import and select “T6_drifts.dxf” 

located in folder “TutorialExamples\6_MeshCleanup_Drifts”. In the Import dialog, select Model → 
Meters and Layout Units → Millimeters, keep other parameters at default values. 

3. If any of the viewport is maximized, double-click on the viewport icon to restore all four views as in 
Figure 65. 

4. Imported objects are located far from the origin and may not be visible. Zoom out to the extent of 
the model by pressing Ctrl+Alt+E. Click on the topographic and drift excavation meshes to ensure 
that they are in separate layers. Delete all layers except for “Default”, “EXCAVATION”, and “TOPO”. 

5. Hover the mouse around the model and pay attention to the coordinates in the lower-left corner of 
the information pane: the displayed coordinates are far from the origin (zero coordinates). This is 
problematic as it limits the number of significant digits available for geometrical manipulations and 
for numerical analysis. It is good practice to translate the model to locate it around the origin. 
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6. Select all objects (Ctrl + A) and type the _Move command. In the Top viewport select the top-left 
corner node as the point to move from and type 0 for the point to move to. Press Ctrl+Alt+E to 
zoom to the new model extents. 

7. Maximize Perspective viewport and select Shaded view (Figure 66). 
8. In the top menu, navigate to View → Display Options… This will open the Rhino Options dialog; 

select View → Display Modes →Shaded → Objects → Curves and set Curve Width to 4. This will 
display all curves thicker in the Shaded view. The initial settings can always be restored by clicking 
on Restore Defaults. 

 
Figure 66: Drift model located near zero coordinates. 

Mesh clean-up 
Two meshes imported from the DXF file contain a number of issues, such as holes, nonconformal faces, 
duplicate faces, naked edges, etc. Such surface meshes are not adequate for creating a valid watertight 
mesh domain suitable for volume meshing. The meshes need to be cleaned up first. 

Rhino has some built-in utilities that allow for checking and summarizing surface mesh issues. One such 
utility can be called by typing the _Check command (try this by selecting all meshes; a pop-up window 
will report a summary of various issues). Another useful command is _MeshRepair. However, using that 
utility for numerous issues may be tedious and cumbersome. Griddle offers the command _GHeal, 
which identifies and displays major surface mesh problems (that otherwise would prevent volume 
meshing) and attempts to fix numerous issues at once. 

9. To check the meshes for naked edges (holes, cracks, disjointed faces) and clashing faces (non-
conformal faces within a single mesh), type _GHeal and select ShowErrors (Figure 67). Two new 
layers will appear: “NAKED_EDGES” (pink curves) and “CLASHING_FACES” (red curves), which 
contain curves outlining corresponding issues. In this case, the layers contain many curves. After 
mesh repair operations, the number of issues (and corresponding curves) will decrease, which can 
be checked by calling _GHeal → ShowErrors again (the outlines of the issues will be updated). To 
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clearly visualize only problematic parts, layers “EXCAVATION” and “TOPO” can be turned off in the 
Layers pane (Figure 68). 

 
Figure 67: Displaying naked edges and clashing faces. 

  
Figure 68: Displaying naked edges and clashing faces with meshes hidden. 

10. To start fixing the meshes, first intersect all non-conformal faces within the meshes using GInt. Set 
tolerance to 0.002 and keep all other parameters at the defaults. After mesh intersections, update 
the outlines of the issues by calling _GHeal → ShowErrors. Note that there are no more clashing 
faces, layer “CLASHING_FACES” is empty, and fewer naked edges remain. 

The remaining issues can be fixed using GHeal in automatic mode with the AutomaticHeal option (the 
manual mode option simply calls Rhino’s _MeshRepair command). AutomaticHeal allows for fixing 
numerous issues at once, but it is important to note that GHeal should be applied to problems 
discretely: only select to fix issues that are expected to be present. In certain cases, it is even better to 
fix issues one by one to get the best results. For example, first FillHoles and FixClashingFaces only, then 
MendCracks and then AlignNormals. In this model, there are holes and a “crack” in the topographic 
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mesh, and there are holes and protrusions (single faces with non-manifold edges) in the drift excavation 
mesh. There are also misaligned normals in both meshes. These issues are fixed in a few steps as 
outlined below. 

11. Select all meshes and use _GHeal → AutomaticHeal → IssuesToFix and set only FillHoles, 
FixClashingFaces, and AlignNormals to Yes, and all others are set to No. Press Enter and keep 
Parameters = Automatic. Press Enter again to run the command. All the holes in the topo and drift 
meshes will be filled, and outlines of the remaining problems will be updated automatically. 

12. There is a big “crack” in the topo mesh, and it cannot be readily fixed by the GHeal command. (If 
GHeal is run with MendCracks = Yes, only half of the crack is “stitched”.) The topo mesh must be 
remeshed first, which will make it easier for GHeal to identify and fix the problems as the mesh 
becomes more uniform and regular (the same applies to the drift excavation mesh). Select the topo 
and drift meshes only (ensure no curves are selected), and remesh them using GSurf with Mode = 
Tri, MinEdgeLength = 0.5, MaxEdgeLength = 5, while all other parameters remain at defaults. A 
rather fine mesh is used to preserve the original mesh details. 

13. Select the topo mesh only and fix the crack using _GHeal → AutomaticHeal → IssuesToFix, set 
MendCracks = Yes and all others to No; press Enter and keep Parameters = Automatic. Now the topo 
mesh contains no issues and has a single naked poly-edge outlining its boundary (Figure 69). 

 
Figure 69: Remeshed and fixed topographic mesh. (The grid is not shown.) 

14. Select the drift mesh only and fix the remaining issues by calling _GHeal → AutomaticHeal → 
IssuesToFix, set RemoveProtrusions = Yes and all others to No, press Enter, and keep Parameters = 
Automatic. After fixing the drift mesh, the only remaining problems are a few faces that stick out 
from the front part of the drift as shown by the pink outlines in Figure 70. They will be resolved later 
when finalizing model construction. 

At this point, all outstanding problems are fixed and the meshes are ready to be used to construct the 
full model. Note that, in general, GHeal’s ability to fix various mesh problems significantly depends on 
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the input mesh itself. Thus, results may vary depending on how the initial meshes are intersected and/or 
remeshed. 

 
Figure 70: Remeshed and fixed drift mesh. (The grid and topographic mesh are not shown.) 

Building model domain and creating volume mesh 
Before final remeshing and volume meshing, a watertight modeling domain must be created. This can 
be done using Griddle’s GExtrude command. 

15. Create a plane using the _Plane command and Center option. Then specify: 
• Center of plane ( Deformable ): 91,-55,-100 
• Other corner or length ( 3Point ): 250 
• Width. Press Enter to use length: 200 

This will create a plane under the drift mesh as shown in Figure 71. 

  
Figure 71: Creating a plane under the drift mesh. 
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16. Select the topo mesh and the plane and type _GExtrude or click on the  icon in the Griddle 

toolbar to extrude the mesh to the plane and create a watertight domain. Use the following 
parameters: ExtrMeshType = Tri, MeshOutput = Merged, MeshMode = Unstructred, MinEdgeLength 
= 0.5, and MaxEdgeLength = 10.  
The command will extrude the topographic mesh along its boundary until the intersection with the 
plane and will create side and bottom meshes. The result should look as shown in Figure 72. 

  
Figure 72: Creating watertight mesh domain with GExtrude command (Ghosted view). 

17. Select and delete the plane. Turn off layers “NAKED_EDGES” and “CLASHING_FACES”. 

Note that a piece of the drift mesh protrudes from the domain mesh. It can be easily separated and 
removed after intersection of meshes and remeshing. 

18. Select all meshes (Ctrl+A) and intersect them using GInt with MeshType = Tri, Tolerance = 0, and 
AdvancedParameters → OutputMesh = Merged. This will create a single conformal mesh. 

19. Remesh the mesh with GSurf using Mode = QuadDom, MinEdgeLength = 1, MaxEdgeLength = 10, 
RidgeAngle=40, and all other parameters at defaults. A large RidgeAngle is used to smooth the 
mesh. Note that the piece of the drift mesh still protrudes from the domain mesh. 

20. To separate the drift mesh from the domain mesh and remove the protruding part of the drift, 

select the whole mesh and type the _GExtract command or click on the  icon in the Griddle 
toolbar. Select option AllSurfaces and use MaxBreakAngle = 180 to separate meshes only along non-
manifold edges (the break angle will not have an effect as it is set to 180°). 

21. Select all meshes and use Griddle’s command _ColorizeObjects or click on the  icon in the 
Griddle toolbar. This will assign a unique color to each mesh piece (Figure 73). 

22. Delete all parts of the drift mesh that protrude from the domain mesh. 
23. If desired, assign specific names to the drift excavation mesh and its front portion (entrance). 
24. The surface meshes are ready for volume meshing. Create a HexDominant mesh using GVol with 

MaxGradation = 1, TargetSize = 7, and set the output format as desired (FLAC3D is used here; note, 
Tet mesh should be used for 3DEC). If a warning about the presence of naked edges appears, press 
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Yes to continue with volume meshing (naked edges are present in the final model due to mesh 
extraction done earlier). Meshing may take some time due to the fine resolution of the topographic 
and drift meshes. The results of the volume mesh imported in FLAC3D are shown in Figure 74. 

  
Figure 73: Meshes separated with the _GExtract command. 

  
Figure 74: Final volume mesh obtained from the cleaned-up DXF meshes. 
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Tutorial 7: Large Open Pit Model with Multiple Intersecting Faults 
Expected work time: 1–3 hours 

Griddle provides powerful tools for cleaning, preparing, and meshing very large models. This tutorial 
describes a workflow that can be used to prepare a large open pit mine model for volume meshing. The 
model contains multiple intersecting faults and stratigraphic layers. Even though the model is artificial, 
the initial surface meshes resemble those that are often obtained from minimally processed field data. 
Note that due to the complex workflow, the user may get slightly different results than those presented 
in the tutorial; however, this should not affect the workflow as a whole. Additionally, it is assumed that 
advanced GInt and GSurf parameters are initially configured to the defaults; this can be achieved by 
restarting Rhino or resetting the parameters through the option GInt, GSurf → AdvancedParameters → 
Reset. 

Navigate to folder “TutorialExamples\7_LargeOpenPitMine”, open file “T7_LargeOpenPitModel.3dm”, 
and examine the model (Figure 75, Figure 76). 

  
Figure 75: Initial model with topographic surface shown. Ghosted view. 

Only a part of the open pit mine is provided in the model. It contains the area of interest (yellow dotted 
line in Figure 76) and includes the pit wall that may have the potential for instability due to several faults 
and a stratigraphic boundary crossing it and due to a large pit dump above the wall. 

Upon examination of the initial model, following observations can be made: 
• There is a single mesh in each layer. Meshes do not have specific names (see Properties pane / F3). 
• Layer “Box” is locked, and it contains a polysurface representing the desired modeling domain. 

The layer is locked to avoid accidental modification of objects within the layer. To enable 
selection and modification of the objects, unlock the layer. 
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Figure 76: Initial model with large pit dump shown. Ghosted view. 

• Surface meshes in layers “Pit”, “Dump”, and “IniTopo” seem to be minimally processed and 
contain a very large number of faces; face reduction may be needed. All other meshes appear to 
be remeshed and trimmed to roughly match the size of the modeling domain. 

• The surface mesh corresponding to the initial topographic surface (layer “IniTopo”) visibly 
contains multiple holes and possibly other issues. 

• None of the meshes appear to be conformal at the areas of contact or intersection. 
• Some of the faults and stratigraphic boundaries seem to terminate on one another. However, it 

is not clear if meshes are in full contact or if there are small gaps between the meshes. 
• Neither “PitDump” nor “Pit” meshes fully connect/intersect to the initial topographic surface. To 

verify if two meshes intersect each other, use the command _MeshIntersect. The command will 
create polylines tracing the intersecting mesh parts (do not forget to delete these polylines 
afterwards). 

• All meshes are located away from zero coordinates but not so far as to have any effect on the 
accuracy of calculations. Thus, there is no need to move the model closer to the origin. 

Preparation of the pit, pit dump, and topo meshes 
1. Turn off all layers except for “IniTopo”. Select the topographic mesh. To make the mesh more 

uniform, remesh it with _GSurf: Mode = Tri, MinEdgeLength = 20, MaxEdgeLength = 100, 
RidgeAngle = 20°, and keep other parameters at the defaults. 

2. After remeshing, some of the initial mesh problems are fixed (e.g., clashing faces). However, the 
mesh still contains several large holes. Fill them using _GHeal → AutomaticHeal → IssuesToFix: 
FillHoles = Yes and all other functions set to No. Keep Parameters = Automatic. After this, ensure 
that there are no more holes (turn on/off “IniTopo” layer) and then delete layers “NAKED_EDGES” 
and “CLASHING_FACES”. 

3. Remesh the topo mesh again with the same parameters used earlier. 
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4. Turn off layer “IniTopo” and turn on layer “Dump”. The mesh representing the pit dump consists of 
a large number of non-uniform triangular faces and working with it may be difficult (in particular, 
remeshing). To check the number of faces in a surface mesh, use the command _PolygonCount; the 
command reports that there are 204,360 triangular polygons in the mesh. 

5. There is no need for such a highly accurate representation of the pit dump, so the number of faces 
in the mesh can be safely reduced without impacting the model. Select the pit dump mesh and type 
_ReduceMesh. In the pop-up dialog, specify to reduce the polygon count by 85%. Keep all other 
parameters at the defaults. 

6. Turn on layers “IniTopo” and “Pit”. Zoom in at any region where meshes visually intersect (e.g., 
Figure 77). One can find that in certain regions, the meshes overlap and protrude through one 
another or conversely, do not fully connect. This is typically due to obtaining meshes from different 
sources and initial mesh processing (including mesh separation, intersection, and remeshing). 

  
Figure 77: Zoomed view of the intersection between the pit, pit dump, and topo meshes. 

Marked regions denote some of the areas where intersections are not perfect. 

Having several meshes (with rather different face sizes) overlap and/or terminate in close proximity to 
one another may present difficulties when using mesh intersector GInt. In this case, it can be challenging 
to find such a GInt tolerance that would be large enough to close all gaps and small enough that 
undesirable mesh deformations do not occur. Also, these nearly overlapping faces present similar 
challenges when remeshing and proceeding with volume meshing. 

The simplest way to approach this challenge is to spatially separate meshes, so there are only two 
meshes intersecting along the same line, making it much easier to select a GInt tolerance to prepare 
meshes for final intersection and remeshing. 

In order to separate the meshes for this model, a thin boundary layer will be extracted from the pit 
dump mesh along a part of its boundary. After that, the pit dump mesh will be extended downward and 
intersected with the topo mesh. 
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7. Turn off layer “IniTopo” and “Pit” layers. 
8. To extract a thin boundary layer, the pit dump mesh must be remeshed such that it contains small 

elements (faces) along the boundary. Select the pit dump mesh and remesh it with _GSurf: Mode = 
Tri, MinEdgeLength = 5, MaxEdgeLength = 5, and RidgeAngle = 60°. Remeshing may take a minute. 
Large RidgeAngle value is used to smooth the mesh. 

9. Select the pit mesh and use the _GExtract → BoundaryFaces option. This operation will extract a 
single layer of faces along the boundary of the mesh. Repeat this operation one more time to 
extract the next boundary layer of faces such that the two outermost rings of boundary faces have 
been separated from the dump mesh (Figure 78).  

  
Figure 78: Boundary faces extracted from the pit dump mesh (note that colors are changed from default gray color). Faces in 

red were separated and will be deleted. 

10. Hide the main pit dump mesh using the _Hide command. The only objects that should be visible are 
the two thin boundary layers of the dump mesh. 

11. Using the _ExtractMeshFaces command, extract the faces from the boundary layers that are closest 
to the pit boundary and those that almost overlap the topo mesh (shown in Figure 78 in red). While 
the command is in face selection mode, other layers can be turned on and off and specific areas can 
be zoomed in/out to help with selection (use the _Zoom command while in selection mode). Note 
that faces can be removed from the selection when pressing Ctrl. 

12. After extracting faces from the layers, delete them (only faces in red in Figure 78). This will create a 
thin gap between the pit mesh and the dump mesh and will avoid having nearly overlapping faces 
between the pit dump and topo meshes. 

13. Unhide the rest of the dump mesh with the _Show command. First select the remaining thin layers 
of faces and add the main pit dump mesh to the selection. Type the _Join command to join all 
meshes. Now a small gap between the pit and the dump meshes can be clearly visible as in Figure 79 
(turn on “Pit” layer to check). 
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Figure 79: A gap between the pit and pit dump meshes. 

14. Select the pit dump mesh and remesh it with _GSurf: Mode = Tri, MinEdgeLength = 20, 
MaxEdgeLength = 100, and RidgeAngle = 60°. This operation will further reduce the number of mesh 
faces and smooth it, making it easier to work with the mesh. Remeshing may take a minute. 

15. Turn off “Pit” layer and turn on “IniTopo” layer. Double-click on the viewport icon in the top-left 
corner of the model view (e.g., ); four standard viewports will be shown. 

16. Select the pit dump mesh and use _GExtend → FreeExtend option. The mesh boundary will be 
highlighted in magenta; select the whole boundary (Ctrl+A) and press Enter. Now the boundary can 
be dragged to a desired location, and the mesh will be extended to the new boundary. 
While the cursor is in drag mode, move it to Front or Right viewports (Figure 80). Then press and 
hold Shift and drag the mouse to position it under the topo mesh as in Figure 80. When the whole 
boundary is below the topo mesh, release the mouse button. This will extend the dump mesh along 
its boundary strictly downwards (Figure 80, Figure 81). 

  
Figure 80: Extension of the pit dump mesh downward along its boundary (FreeExtend mode). 
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The same operation can be done by using _GExtend → ExtendSelectedBoundary and specifying 
ExtendLength = 150 and Direction = AlongVector. Select the whole boundary and type 0,0,0 for the 
beginning of the extension vector and 0,0,-1 for the end. This will extend the mesh downwards. 

 
Figure 81: Extended pit dump mesh fully intersecting topo mesh. 

Now the dump and topo meshes fully intersect each other. A similar process will be used to extend part 
of the pit mesh; however, the pit mesh must be remeshed first. 

17. Turn on the “Pit” layer and turn off all others. Remesh the pit mesh with _GSurf: Mode = Tri, 
MinEdgeLength = 10, MaxEdgeLength = 40, and RidgeAngle = 20°. 
Restore all four viewports by double-clicking on the current viewport icon (if any viewport is 
maximized). Turn on layer “Box” and switch Top viewport to Ghosted view. Select the pit dump 
mesh and use the _GExtend → FreeExtend option. Select only the top part of the pit boundary in 
such a way that the selection goes a little beyond the box but not to the corner points of the top 
boundary4, as in Figure 82. Like before, move the cursor to Front or Right viewports and while 
holding Shift, drag the mouse upward, so the extended mesh is sure to intersect the topo mesh (the 
exact extension length does not matter). The resulting mesh should look similar to Figure 83. 

18. Navigate to the Layers pane and unlock layer “Box” (click on the lock icon). Turn on the layer if it is 
turned off. Mesh the box polysurface with the _Mesh command, using simple controls and the 
fewest number of polygons. After meshing, the polysurface is still selected. Delete it. 

At this point, the pit, pit dump, topo, and box meshes are in full contact. Now they can be easily 
intersected and excessive parts removed. The approach described below intersects and merges meshes 
and then separates sub-meshes along nonmanifold edges5. 

 
4 Extending a part of the top pit boundary (not whole) allows for later extraction of sub-meshes along non-
manifold intersection lines. If the whole top boundary of the pit mesh is extended, the faces around the corners 
may connect without forming non-manifold connections. 
5 An alternative approach is to use Rhino’s _MeshSplit command. However, the command does not work properly 
in Rhino 6; it was fixed in Rhino 7. If using Rhino 7 or later, the user can split one mesh by another provided they 
are conformal (intersect with GInt, OutputMesh = Separated). This approach is simpler than the one outlined here. 
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Figure 82: Selection of a piece of the pit boundary for mesh extension. 

  
Figure 83: Extended pit mesh. Note that the mesh is not extended all the way to the corner points of its top boundary. 

19. Select the pit, pit dump, topo, and box meshes and intersect them with _GInt → Tolerance = 0, 
AdvancedParameters: OutputMesh = Merged, and keep other parameters at the defaults. This will 
create a single conformal nonmanifold mesh within the current (“Default”) layer. 

20. Select the merged mesh and use _GExtract → AllSurfaces: MaxBreakAngle = 180 to extract meshes 
along the nonmanifold edges (the break angle will not have an effect as it is set to 180°). 

21. Delete the top part of the extracted box mesh, excessive parts of the topo, pit, and dump meshes 
that extend through the topo and beyond box mesh. Merge all pieces of the box mesh and all pieces 
of the topo mesh (including the pieces underneath the dump and overtop of the pit) using the _Join 



Griddle v2.00.14, Tutorial Examples, rev112423 59 

command. In the Properties pane, reassign layer “Box” to the box mesh, layer “IniTopo” to the topo 
mesh, layer “Dump” to the dump mesh, and layer “Pit” to the pit mesh. 

22. Turn off all layers except for the default layer (e.g., “Default”). Check if there are any small pieces of 
meshes left after the extraction; press Ctrl+A to select all of them. Usually, these would be narrow 
single faces6 that may not be visible when larger objects are present. Ensure that no more than a 
few pieces are present (there will most likely be only one piece selected). Delete these pieces. If 
there are many small pieces, most likely the meshes were not intersected or extracted properly; 
undo and repeat the last several steps according to the instructions. 

23. Turn layers “Box”, “IniTopo”, “Dump”, and “Pit” back on. Select all meshes and use _GHeal → 
ShowErrors to check if there are any internal naked edges. Turn off layer “CLASHING_FACES” (they 
will be fixed by remeshing) and type the command _SelCrv to select the outlines of naked edges. 
The command should report that only four curves are selected. If this is the case, delete the curves 
while they are selected. If more than four curves are present, there are holes within some of the 
meshes, which is likely due to incorrect mesh intersection or extraction; undo and repeat the last 
several steps according to the instructions. 

24. All four meshes should be remeshed to make them more uniform and to simplify further work. First, 
assign a specific element size to each mesh in the hyperlink field of the mesh properties pane (F3): 

• The box and topo meshes: elemsize:75 
• The pit dump mesh: elemsize:25 
• The pit mesh: elemsize:15 

Then use _GSurf: Mode = Tri, MinEdgeLength = 10, MaxEdgeLength = 100, and RidgeAngle = 20° to 
remesh all four meshes. The resulting meshes should look like that in Figure 84. 

  
Figure 84: Intersected box, pit, pit dump, and topo meshes (Ghosted view). 

 
6 If there are extremely small / thin faces around mesh intersection areas (which sometimes happens after 
intersecting meshes), GExtract may extract such small pieces and create separate mesh objects from them. 
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At this point, a volume mesh could be created from the surface meshes shown Figure 84. However, the 
model does not yet include faults. The next section provides information about extending, intersecting, 
and trimming faults before including them into the model. 

Preparation of the fault meshes 
Turn on “Faults” layers and turn off all others. Explore the areas where meshes visually terminate on 
one another and/or use the _MeshIntersect command to see if there is full intersection between 
meshes. Mesh “Strat1” should terminate on “Fault1” and the rest of the fault meshes should terminate 
on “Strat2”. Unfortunately, none of these meshes fully intersect/terminate as they should (e.g., see 
Figure 85). This is a common situation when working with meshes generated from field data. As before, 
such meshes need to be extended, properly intersected, and then excessive pieces removed. 

  
Figure 85: The _MeshIntersect command shows actual intersections (yellow lines) between “Fault4” and “Strat2” meshes. 

Other parts of the “Fault4” mesh do not intersect the “Strat2” mesh, leaving minor gaps. 

25. Turn on only “Strat1” and “Fault1” layers and extend the “Strat1” mesh only along the edge that 
visually connects to the “Fault1” mesh. Use _GExtend → ExtendSelectedBoundary: ExtendLength = 
20, MeshType = Merged. Additional segments of the boundary can be included in the selection by 
clicking on them and can be removed when holding Ctrl and clicking. Ensure that the extended 
portion fully intersects and is enclosed within the “Fault1” mesh (as in Figure 86). 

26. Repeat this operation to extend meshes “Fault2”, “Fault3”, and “Fault4” so they extend through the 
“Strat2” mesh. Use the same _GExtend parameters as in the previous step. Ensure that the 
extended parts fully intersect and are enclosed within the “Strat2” mesh (zoom in at intersection 
corners). 

27. Turn on layers “Box”, “Strat1”, and “Fault1” and turn off all other layers. Intersect all three meshes 
with _GInt → AdvancedParameters: OutputMesh = Merged, Tolerance = 0, and keep other 
parameters at the defaults. This will create a single conformal nonmanifold mesh within the current 
(“Default”) layer. 
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Figure 86: Extension of “Strat1” mesh along the part of the boundary closest to “Fault1”. 

28. Use _GExtract → AllSurfaces: MaxBreakAngle = 180 to extract meshes along nonmanifold edges 
(break angle will not have an effect as it is set to 180°). 

29. Delete excessive parts of meshes located outside the box. Hide the box with the _Hide command 
and delete the excessive part of the “Strat1” mesh extending through the “Fault1” mesh. In the 
Properties pane, reassign layers “Strat1” and “Fault1” to the corresponding meshes. 

30. Show the box using the _Show command. The box is still in the “Default” layer, no need to reassign 
it yet. Turn off layers “Strat1” and “Fault1” and turn on layers “Strat2” and “Fault2”. Repeat the 
operations from the previous three steps to intersect, separate, and remove excessive mesh parts. 
Note that the box will be split in two pieces during these operations. There is no need to join them 
and reassign layers “Box” and “Strat2” until all meshes are intersected and excessive parts removed. 

31. Repeat the previous four steps for “Fault3” and “Fault4” meshes. Remember to include the box 
when intersecting (in case it was hidden earlier) and to delete thin mesh pieces underneath the 
“Strat2” mesh. 

32. Join two pieces of the box mesh and place them into the “Box” layer (_Join). Join (up to five) pieces 
of the “Strat2” mesh and place them in the “Strat2” layer. Turn on all “Faults” and “Box” layers only. 

Now there should only be seven meshes, as in Figure 87 (check with Ctrl+A). All these meshes are 
perfectly intersected between one another and are ready to be intersected with the pit, pit dump, and 
topo meshes, followed by final remeshing and volume meshing. 

Final mesh intersection and remeshing 
33. Turn on all the layers. Select all meshes and intersect them using _GInt → Tolerance = 0.001, 

AdvancedParameters: OutputMesh = Separated. 
34. Remesh all meshes using _GSurf: Mode = Tri, MinEdgeLength = 10, MaxEdgeLength = 75, RidgeAngle 

= 10° and AdvancedParameters: MaxGradation = 0.2, Optimization = 10, ShapeQuality = 0.9, and 
OutputMesh = Separated. The results are shown in Figure 88. 
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Figure 87: Intersected and trimmed “Faults” meshes. 

  
Figure 88: Final triangular surface meshes (the pit dump and topo meshes are not shown). 

35. Verify that the final surface meshes do not contain any holes or clashing faces by calling _GHeal → 
ShowErrors (select all meshes first). After that, type _SelCrv. Rhino should report that only 10 curves 
are selected. 
If more than 10 curves are selected, that indicates the presence of nonconformal faces, internal 
holes, and/or clashing faces. To locate issues, hide all layers except for “NAKED_EDGES” and 
“CLASHING_FACES” and start deleting large curves corresponding to mesh boundaries (there should 
be 10 curves). Any curves left indicate potential issues. 
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If any issues are present, investigate each problematic area. It may happen that some nearly overlapping 
faces from different meshes got merged into a single face during remeshing. In such a case, one of the 
meshes may contain a hole. An example of this is shown in Figure 89, which was obtained when 
conducting step 24 of this tutorial with RidgeAngle = 10°. In this case, nearly overlapping faces from the 
pit mesh and the topo mesh got merged after remeshing, and the resulting single face got assigned to 
the pit mesh only. This is not a critical issue as meshes still form a watertight domain and the volume 
mesh can be generated. The only negative consequence is that the face group designating mesh surface 
within the volume mesh may contain a hole or the wrong group would be assigned to the “overlapping” 
face7. Such situations are more often encountered when working with models containing a large 
number of faults intersecting at very small angles (so faces from one mesh are very close to the faces 
from another mesh near intersections; depending on which remeshing parameters are used, some faces 
may become merged between meshes). 

  
Figure 89: Overlapping faces (in blue) created a hole in the topo mesh. 

36. Assign names in the meshes Properties pane as desired. These names will be transferred as named 
face groups (surfaces) to the volume mesh (currently, only for FLAC3D and 3DEC). See details about 
group naming and surface naming in the Griddle 2.0 User Manual. 

37. Create a tetrahedral volume mesh in FLAC3D binary format. Keep all other GVol parameters at 
default values. Tetrahedral volume mesh generation is usually a fast process8, and it is used here. In 
case Griddle issues a message about the presence of naked edges, read the message and press Yes 
to continue. The final mesh is shown in Figure 90. 

 
7 Fixing the hole created by overlapping faces will not resolve the situation, as no volume elements are created 
between the overlapping faces (there is zero volume between them). 
8 In general, it is much easier to generate pure tetrahedral meshes for very complex models, as filling any random 
volume with tetrahedrons is a simpler process than filling a volume with a combination of various shapes. Besides, 
the average quality of tetrahedral elements in such cases is typically higher than for hex-dominant meshes. 
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Figure 90: Tetrahedral volume mesh of open pit mine model. 

As an optional exercise, remesh all meshes again using the same GSurf parameters as in step 34 but with 
QuadDom mesh type. Then generate a hex-dominant (HexDom) volume mesh in FLAC3D binary format 
(which may take several minutes for such a large model). Save the file under a different name than the 
previous file. Compare log outputs from GVol for both cases to see what kind and how many elements 
are generated. 

When generating the hex-dominant volume mesh for the model, GVol will produce about half of the 
total number of elements compared to a tetrahedral mesh. However, a HexDom mesh contains a large 
number of undesirable pyramidal elements9. For such complex models, engineers often generate pure 
tetrahedral meshes and then split each tetrahedron into several hexahedrons within FLAC3D to obtain a 
pure hexahedral grid (pure hexahedral grids yield significantly more accurate numerical results in 
FLAC3D). 

Note that this model is not suitable for outputting in 3DEC deformable blocks format as faults do not 
connect to the topo mesh, and, thus, they do not cut blocks within the pit or the rest of the model. 3DEC 
rigid block format could be used instead, but the surface meshes will need to be significantly coarsened 
first to produce a coarser volume mesh that can be loaded into 3DEC (as 3DEC will try to detect and 
create a contact between each rigid tetrahedral element/block, resulting in an enormous amount of 
block contacts). 

 
9 FLAC3D grid densification becomes rather challenging if pyramids are present. 
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